<!DOCTYPE html><html lang="en-US" class="no-js" itemscope itemtype="https://schema.org/Article"><head><meta charset="UTF-8" /> <script data-ad-client="ca-pub-5266060762538651" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><title>Have Browns Fans Gotten too Low on Baker Mayfield? | Waiting For Next Year</title><meta name="format-detection" content="telephone=no"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><link rel="shortcut icon" href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny2.png" type="image/x-icon" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//waitingfornext-a.akamaihd.net' /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Feed" href="https://waitingfornextyear.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Comments Feed" href="https://waitingfornextyear.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Have Browns Fans Gotten too Low on Baker Mayfield? Comments Feed" href="https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://waitingfornextyear.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wpt-twitter-feed-css' href='https://waitingfornextyear.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' /><link rel='stylesheet' id='style-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/style-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-base-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/base-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-layout-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/layout-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-shortcodes-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/shortcodes-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-animations-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/animations/animations.min-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-jquery-ui-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/ui/jquery.ui.all-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-jplayer-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/jplayer/css/jplayer.blue.monday-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-responsive-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/responsive-21.6.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-fonts-css' href='https://fonts.googleapis.com/css?family=Hind+Madurai%3A1%2C400%2C500%2C700%7CUbuntu%3A1%2C400%2C500%2C700%7CPatua+One%3A1%2C400%2C500%2C700&#038;ver=5.4.1' type='text/css' media='all' /><style id='mfn-dynamic-inline-css' type='text/css'>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</style><style id='mfn-custom-inline-css' type='text/css'>.footer-copy-center #Footer .footer_copy .copyright{font-size:12px;line-height:16px}.post-footer{display:none}</style><link rel='stylesheet' id='wdfb_style-css' href='https://waitingfornextyear.com/wp-content/plugins/wpmu-dev-facebook/css/wdfb.css' type='text/css' media='all' /> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js'></script> <link rel='https://api.w.org/' href='https://waitingfornextyear.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://waitingfornextyear.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://waitingfornextyear.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Zack Meisel joins the Dery Bros to talk 1995 Tribe' href='https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/' /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='https://waitingfornextyear.com/?p=211956' /><meta property="fb:pages" content="20512657575" /><meta property="ia:markup_url" content="https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/?ia_markup=1" /><link type="text/css" rel="stylesheet" href="https://waitingfornextyear.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="@WFNYCLE" /><meta name="twitter:creator" content="@WFNYCraig" /><meta name="twitter:url" content="https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/" /><meta name="twitter:title" content="Have Browns Fans Gotten too Low on Baker Mayfield?" /><meta name="twitter:description" content="I get the sense that many Browns fans are down on Baker Mayfield. Maybe we were once too high on him after his rookie season, but […]" /><meta name="twitter:image" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo.jpg" /> <style type="text/css">ol.footnotes li{list-style-type:decimal}</style><link rel="canonical" href="https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/" /><meta name="description" content="I get the sense that many Browns fans are down on Baker Mayfield. Maybe we were once too high on him after his rookie season, but I think we&#039;re now too low on him thanks to the Freddie Kitchens debacle. Also, it was great to see the UFC come back, and whatever Stipe Miocic decides to do nex ..." />  <script type="text/javascript">var _wdfb_ajaxurl="https://waitingfornextyear.com/wp-admin/admin-ajax.php";var _wdfb_root_url="https://waitingfornextyear.com/wp-content/plugins/wpmu-dev-facebook";</script><meta property='fb:app_id' content='106265117682' /><meta property='og:type' content='article' /><meta property='og:title' content='Have Browns Fans Gotten too Low on Baker Mayfield?' /><meta property='og:url' content='https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/' /><meta property='og:site_name' content='Waiting For Next Year' /><meta property='og:description' content='I get the sense that many Browns fans are down on Baker Mayfield. Maybe we were once too high on him after his rookie season, but I think we&#039;re now too low on him thanks to the Freddie Kitchens debacle. Also, it was great to see the UFC c...' /><meta property='og:image' content='https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo-1024x576.jpg' />  <script type="text/javascript">( function( i, s, o, g, r, a, m ) {
		i[ 'GoogleAnalyticsObject' ] = r;
		i[ r ] = i[ r ] || function() {
			( i[ r ].q = i[ r ].q || [] ).push( arguments )
		}, i[ r ].l = 1 * new Date();
		a = s.createElement( o ),
			m = s.getElementsByTagName( o )[ 0 ];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore( a, m )
	} )( window, document, 'script', 'https://waitingfornextyear.com/wp-content/cache/busting/google-tracking/ga-af5c617d36e28d19710b882a6824e213.js', 'beehive_ga' );

	function beehive_ga_track() {
							beehive_ga( 'create', 'UA-36605884-1', 'auto', { 'name': 'single' } ); // Create single site tracking.
												beehive_ga( 'single.send', 'pageview' ); // Send pageview.
			}

			beehive_ga_track(); // Load tracking.</script> <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-211956 single-format-standard with_aside aside_right color-custom style-default button-default layout-full-width if-disable if-border-hide hide-love no-shadows header-stack header-magazine minimalist-header sticky-header sticky-white ab-hide subheader-title-left menu-line-below-80-1 menuo-no-borders footer-copy-center boxed2fw mobile-tb-center mobile-mini-mr-ll mobile-header-mini be-reg-2161 wpb-js-composer js-comp-ver-6.1 vc_responsive"><div id="fb-root"></div> <script async defer src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=449813798444257&autoLogAppEvents=1"></script><div id="Wrapper"><div id="Header_wrapper" class="" ><header id="Header"><div class="header_placeholder"></div><div id="Top_bar" class="loading"><div class="container"><div class="column one"><div class="top_bar_left clearfix"><div class="logo"><a id="logo" href="https://waitingfornextyear.com" title="Waiting For Next Year" data-height="60" data-padding="10"><img class="logo-main scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /><img class="logo-sticky scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-dark.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-dark-2x.png" data-height="99" alt="wfny-logo-dark" data-no-retina /><img class="logo-mobile scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /><img class="logo-mobile-sticky scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /></a></div><div class="menu_wrapper"><nav id="menu"><ul id="menu-main-menu-2" class="menu menu-main"><li id="menu-item-204199" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-indians-archive/"><span>Indians</span></a></li><li id="menu-item-204205" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-browns-archive/"><span>Browns</span></a></li><li id="menu-item-204204" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-cavs-archive/"><span>Cavs</span></a></li><li id="menu-item-204254" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/ohio-state-buckeyes-archive/"><span>Buckeyes</span></a></li><li id="menu-item-127673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#"><span>Other Sports</span></a><ul class="sub-menu"><li id="menu-item-204266" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/college-sports-archive/"><span>College Sports</span></a></li><li id="menu-item-204265" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/minor-league-baseball-archive/"><span>Minor League Baseball</span></a></li><li id="menu-item-204264" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/other-sports-archive/"><span>Other Sports</span></a></li></ul></li><li id="menu-item-204263" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/podcast-archive/"><span>Podcast</span></a></li></ul></nav><a class="responsive-menu-toggle " href="#"><i class="icon-menu-fine"></i></a></div><div class="secondary_menu_wrapper"></div><div class="banner_wrapper"> <ins class="adsbygoogle" style="width:468px;height:60px" data-ad-client="ca-pub-5266060762538651" data-ad-slot="6641400053"></ins></div><div class="search_wrapper"><form method="get" id="searchform" action="https://waitingfornextyear.com/"> <i class="icon_search icon-search-fine"></i> <a href="#" class="icon_close"><i class="icon-cancel-fine"></i></a> <input type="text" class="field" name="s" placeholder="Enter your search" /> <input type="submit" class="display-none" value="" /></form></div></div></div></div></div></header><div id="Subheader"><div class="container"><div class="column one"><h1 class="title">Have Browns Fans Gotten too Low on Baker Mayfield?</h1></div></div></div></div><div id="Content"><div class="content_wrapper clearfix"><div class="sections_group"><div id="post-211956" class="no-title no-share share-simple post-211956 post type-post status-publish format-standard has-post-thumbnail hentry category-podcast tag-baker-mayfield tag-browns tag-dana-white tag-daniel-cormier tag-stipe-miocic tag-ufc"> <a class="fixed-nav fixed-nav-prev format- style-arrows" href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/"><span class="arrow"><i class="icon-left-open-big"></i></span><div class="photo"><img width="80" height="80" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-80x80.jpg" class="attachment-blog-navi size-blog-navi wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-80x80.jpg 80w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-150x150.jpg 150w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-85x85.jpg 85w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-45x45.jpg 45w" sizes="(max-width: 80px) 100vw, 80px" /></div><div class="desc"><h6>Zack Meisel joins the Dery Bros to talk 1995 Tribe</h6><span class="date"><i class="icon-clock"></i>May 15, 2020</span></div></a><div class="section section-post-header"><div class="section_wrapper clearfix"><div class="column one post-header"><div class="title_wrapper"><div class="post-meta clearfix"><div class="author-date"> <span class="vcard author post-author" itemprop="author" itemscope itemtype="https://schema.org/Person"> <span class="label">Published by</span> <i class="icon-user"></i> <span class="fn" itemprop="name"><a href="https://waitingfornextyear.com/author/craig/">Craig Lyndall</a></span> </span> <span class="date"> <span class="label">on</span> <i class="icon-clock"></i> <time class="entry-date updated" datetime="2020-05-15T17:00:59-04:00" itemprop="datePublished" >May 15, 2020</time><meta itemprop="dateModified" content="2020-05-15T17:00:59-04:00"/> </span><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization" style="display:none;"><meta itemprop="name" content="Waiting For Next Year"/><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" itemprop="url" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png"/></div></div></div></div></div></div><div class="column one single-photo-wrapper image"><div class="image_frame scale-with-grid "><div class="image_wrapper"> <a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo-1024x576.jpg" rel="prettyphoto"><div class="mask"></div><div itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><img width="853" height="480" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo.jpg" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo.jpg 2034w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo-768x432.jpg 768w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo-1024x576.jpg 1024w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo-710x400.jpg 710w" sizes="(max-width: 853px) 100vw, 853px" /><meta itemprop="url" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo.jpg"/><meta itemprop="width" content=""/><meta itemprop="height" content=""/></div></a><div class="image_links"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/08/WFNY-Podcast-Wide-Logo-1024x576.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a></div></div></div></div></div></div><div class="post-wrapper-content"><div class="section the_content has_content"><div class="section_wrapper"><div class="the_content_wrapper"><div class="wdfb_like_button"><fb:like href="https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/" send="true" layout="button_count" width="450" colorscheme="light" show_faces="true" font=""></fb:like></div><p>I get the sense that many Browns fans are down on Baker Mayfield. Maybe we were once too high on him after his rookie season, but I think we&#8217;re now too low on him thanks to the Freddie Kitchens debacle.</p><p>Also, it was great to see the UFC come back, and whatever Stipe Miocic decides to do next, he doesn&#8217;t owe anyone anything.</p><p><iframe style="border: none" src="//html5-player.libsyn.com/embed/episode/id/14417780/height/90/theme/custom/thumbnail/yes/direction/forward/render-playlist/no/custom-color/000000/" height="90" width="100%" scrolling="no" allowfullscreen webkitallowfullscreen mozallowfullscreen oallowfullscreen msallowfullscreen></iframe></p><div class="bIvpOJXD" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-5266060762538651" data-ad-slot="2849801225"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><div class="wdfb_like_button"><fb:like href="https://waitingfornextyear.com/2020/05/have-browns-fans-gotten-to-low-on-baker-mayfield/" send="true" layout="button_count" width="450" colorscheme="light" show_faces="true" font=""></fb:like></div></div></div></div><div class="section section-post-footer"><div class="section_wrapper clearfix"><div class="column one post-pager"></div></div></div><div class="section section-post-about"><div class="section_wrapper clearfix"></div></div></div><div class="section section-post-related"><div class="section_wrapper clearfix"><div class="section-related-adjustment "><h4>Related posts</h4><div class="section-related-ul col-3"><div class="column post-related post-211952 post type-post status-publish format-standard has-post-thumbnail hentry category-podcast tag-albert-belle tag-carlos-baerga tag-indians tag-kenny-lofton tag-mike-hargrove tag-sandy-alomar"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/"><div class="mask"></div><img width="900" height="500" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast.jpg" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast.jpg 900w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-768x427.jpg 768w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-260x144.jpg 260w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-50x28.jpg 50w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-135x75.jpg 135w" sizes="(max-width: 900px) 100vw, 900px" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/" class="link"><i class="icon-link"></i></a></div></div></div></div><div class="date_label">May 15, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/">Zack Meisel joins the Dery Bros to talk 1995 Tribe</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div><div class="column post-related post-211857 post type-post status-publish format-standard has-post-thumbnail hentry category-podcast"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/05/086-browns-draft-grades-when-will-sports-return-andy-jarid-cleveland-beyond/"><div class="mask"></div><img width="931" height="524" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1.jpg" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1.jpg 931w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1-768x432.jpg 768w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1-260x146.jpg 260w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1-50x28.jpg 50w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1-133x75.jpg 133w" sizes="(max-width: 931px) 100vw, 931px" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Jedrick-Wills-REUTERS-1.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/05/086-browns-draft-grades-when-will-sports-return-andy-jarid-cleveland-beyond/" class="link"><i class="icon-link"></i></a></div></div></div></div><div class="date_label">May 5, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/05/086-browns-draft-grades-when-will-sports-return-andy-jarid-cleveland-beyond/">086 &#8211; Browns Draft Grades, When Will Sports Return? &#8212; Andy &#038; Jarid, Cleveland &#038; Beyond</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/05/086-browns-draft-grades-when-will-sports-return-andy-jarid-cleveland-beyond/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div><div class="column post-related post-211609 post type-post status-publish format-standard has-post-thumbnail hentry category-podcast tag-bulls tag-michael-jordan tag-nfl-draft tag-sports-documentaries"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/04/nail-in-the-coffin-podcast-the-last-dance-michael-jordan-nfl-draft/"><div class="mask"></div><img width="960" height="750" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/IMG_9146-960x750.jpg" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/IMG_9146-960x750.jpg 960w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/IMG_9146-1280x1000.jpg 1280w" sizes="(max-width: 960px) 100vw, 960px" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/IMG_9146-1024x576.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/04/nail-in-the-coffin-podcast-the-last-dance-michael-jordan-nfl-draft/" class="link"><i class="icon-link"></i></a></div></div><p class="wp-caption-text hide">Photo from Chicago Tribune/WFNY photo illustration</p></div></div><div class="date_label">April 21, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/04/nail-in-the-coffin-podcast-the-last-dance-michael-jordan-nfl-draft/">Jordan and the Bulls’ “Last Dance,” NFL Draft trainwreck potential – The Nail in the Coffin, Episode 174</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/04/nail-in-the-coffin-podcast-the-last-dance-michael-jordan-nfl-draft/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div></div></div></div></div><div class="section section-post-comments"><div class="section_wrapper clearfix"><div class="column one comments"><div id="disqus_thread"></div></div></div></div></div></div><div class="mcb-sidebar sidebar sidebar-1 four columns "><div class="widget-area"><div class="inner-wrapper-sticky clearfix"><aside id="custom_html-2" class="widget_text widget widget_custom_html"><h3>WANT TO SUPPORT WFNY?</h3><div class="textwidget custom-html-widget"><a href="http://patreon.com/wfny" target="_blank" rel="nofollow noopener noreferrer"><img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/09/become_a_patron_button.png"></a></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><h3>BUY WFNY GEAR!</h3><div class="textwidget custom-html-widget"><a href="http://wfny.threadless.com/" target="_blank" rel="nofollow noopener noreferrer"><img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2018/02/WFNYX-tshirt-sample.jpg"></a></div></aside><aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5266060762538651" data-ad-slot="7449450699" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><h3>WFNY PODCAST</h3><div class="textwidget custom-html-widget"><iframe style="border: none" src="//html5-player.libsyn.com/embed/destination/id/134539/height/500/theme/custom/thumbnail/yes/preload/no/direction/backward/no-cache/true/render-playlist/yes/custom-color/2e1094/" height="500" width="100%" scrolling="no" allowfullscreen webkitallowfullscreen mozallowfullscreen oallowfullscreen msallowfullscreen></iframe> <br><br> <a href="https://www.facebook.com/WFNYPod" target="_blank" rel="noopener noreferrer">The WFNY Podcast Facebook Page</a><br><br> <a href="https://itunes.apple.com/us/podcast/the-official-waiting-for-next-year-podcast/id569883258?mt=2" target="_blank" rel="noopener noreferrer">WFNY Podcast on iTunes</a></div></aside><aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="fb-page" data-href="https://www.facebook.com/waitingfornextyear/" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/waitingfornextyear/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/waitingfornextyear/">Waiting For Next Year - WFNY</a></blockquote></div></div></aside><style>.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type:none}.rpwe-block a{display:inline!important;text-decoration:none}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:14px!important;line-height:1.5em}.rpwe-thumb{border:1px solid #eee!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important}.rpwe-summary{font-size:12px}.rpwe-time{color:#bbb;font-size:11px}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px}.rpwe-alignleft{display:inline;float:left}.rpwe-alignright{display:inline;float:right}.rpwe-aligncenter{display:block;margin-left:auto;margin-right:auto}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table!important}.rpwe-clearfix:after{clear:both}.rpwe-clearfix{zoom:1}</style><aside id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h3>LOOK &#038; LISTEN</h3><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Copy-of-Copy-of-Tribecast-45x45.jpg" alt="Zack Meisel joins the Dery Bros to talk 1995 Tribe"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/zack-meisel-joins-the-dery-bros-to-talk-1995-tribe/" title="Permalink to Zack Meisel joins the Dery Bros to talk 1995 Tribe" rel="bookmark">Zack Meisel joins the Dery Bros to talk 1995 Tribe</a></h3><time class="rpwe-time published" datetime="2020-05-15T15:00:48-04:00">May 15, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/joe-burrow-vs-baker-mayfield-is-a-victim-of-circumstance-competition/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/VS.-45x45.jpg" alt="Joe Burrow vs. Baker Mayfield is a Victim of Circumstance Competition"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/joe-burrow-vs-baker-mayfield-is-a-victim-of-circumstance-competition/" title="Permalink to Joe Burrow vs. Baker Mayfield is a Victim of Circumstance Competition" rel="bookmark">Joe Burrow vs. Baker Mayfield is a Victim of Circumstance Competition</a></h3><time class="rpwe-time published" datetime="2020-05-15T11:30:05-04:00">May 15, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/browns-2020-schedule-past-present-history/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/B-Mayfield-45x45.jpg" alt="The Past vs. the Future: 2020 Cleveland Browns’ Opponents"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/browns-2020-schedule-past-present-history/" title="Permalink to The Past vs. the Future: 2020 Cleveland Browns’ Opponents" rel="bookmark">The Past vs. the Future: 2020 Cleveland Browns’ Opponents</a></h3><time class="rpwe-time published" datetime="2020-05-15T08:55:09-04:00">May 15, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/browns-film-room-2020-nfl-draft-jordan-elliott/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/hi-res-f11360b0373200d9daf6571913325f1f_crop_north-45x45.jpg" alt="2020 Browns’ NFL Draft Film Room Series: IDL Jordan Elliott"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/browns-film-room-2020-nfl-draft-jordan-elliott/" title="Permalink to 2020 Browns’ NFL Draft Film Room Series: IDL Jordan Elliott" rel="bookmark">2020 Browns’ NFL Draft Film Room Series: IDL Jordan Elliott</a></h3><time class="rpwe-time published" datetime="2020-05-14T08:55:59-04:00">May 14, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/browns-strength-of-schedule-2020-las-vegas/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/09/Baker-Landry-and-Beckham-45x45.jpg" alt="Browns have a favorable schedule in 2020"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/browns-strength-of-schedule-2020-las-vegas/" title="Permalink to Browns have a favorable schedule in 2020" rel="bookmark">Browns have a favorable schedule in 2020</a></h3><time class="rpwe-time published" datetime="2020-05-13T08:55:18-04:00">May 13, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/cleveland-indians-baseball-moving-closer-to-happening-2020-coronavirus/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/download-45x45.jpg" alt="Could it be true? Baseball on the horizon?"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/cleveland-indians-baseball-moving-closer-to-happening-2020-coronavirus/" title="Permalink to Could it be true? Baseball on the horizon?" rel="bookmark">Could it be true? Baseball on the horizon?</a></h3><time class="rpwe-time published" datetime="2020-05-12T11:25:54-04:00">May 12, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/browns-multiple-tight-ends-personnel-groupings-baker-mayfield-kevin-stefanski/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/jjlwiro7chhe7lanyidr-45x45.jpeg" alt="The more tight ends the merrier for the Browns offense"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/browns-multiple-tight-ends-personnel-groupings-baker-mayfield-kevin-stefanski/" title="Permalink to The more tight ends the merrier for the Browns offense" rel="bookmark">The more tight ends the merrier for the Browns offense</a></h3><time class="rpwe-time published" datetime="2020-05-11T10:55:45-04:00">May 11, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/game-of-thrones-cleveland-indians/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/Baseball-is-coming-45x45.jpg" alt="Game of Thrones: Baseball is Coming"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/game-of-thrones-cleveland-indians/" title="Permalink to Game of Thrones: Baseball is Coming" rel="bookmark">Game of Thrones: Baseball is Coming</a></h3><time class="rpwe-time published" datetime="2020-05-11T09:55:56-04:00">May 11, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/browns-2020-schedule-game/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/2-Minute-Drill_-Browns-Unveil-2020-Schedule-Google-Chrome-5_7_2020-8_33_08-PM-3-45x45.png" alt="The 2020 Browns&#8217; Schedule Game: WFNY Roundtable"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/browns-2020-schedule-game/" title="Permalink to The 2020 Browns&#8217; Schedule Game: WFNY Roundtable" rel="bookmark">The 2020 Browns&#8217; Schedule Game: WFNY Roundtable</a></h3><time class="rpwe-time published" datetime="2020-05-11T08:55:17-04:00">May 11, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/05/087-browns-schedule-game-nba-update-andy-jarid-cleveland-beyond/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/05/2-Minute-Drill_-Browns-Unveil-2020-Schedule-Google-Chrome-5_7_2020-8_33_08-PM-3-45x45.png" alt="087 &#8211; Browns Schedule Game, NBA Update &#8212; Andy &#038; Jarid, Cleveland &#038; Beyond"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/05/087-browns-schedule-game-nba-update-andy-jarid-cleveland-beyond/" title="Permalink to 087 &#8211; Browns Schedule Game, NBA Update &#8212; Andy &#038; Jarid, Cleveland &#038; Beyond" rel="bookmark">087 &#8211; Browns Schedule Game, NBA Update &#8212; Andy &#038; Jarid, Cleveland &#038; Beyond</a></h3><time class="rpwe-time published" datetime="2020-05-10T18:40:17-04:00">May 10, 2020</time></li></ul></div></aside></div></div></div></div></div> <script type="text/javascript" src="https://connect.facebook.net/en_US/all.js"></script><div id='fb-root'></div><script type='text/javascript'>FB.init({
	            appId: '106265117682',
	            status: true,
	            cookie: true,
	            xfbml: true,
	            oauth: true
	         });</script> <footer id="Footer" class="clearfix"><div class="widgets_wrapper "><div class="container"><div class="column one-third"><aside id="search-3" class="widget widget_search"><form method="get" id="searchform" action="https://waitingfornextyear.com/"> <i class="icon_search icon-search-fine"></i> <a href="#" class="icon_close"><i class="icon-cancel-fine"></i></a> <input type="text" class="field" name="s" placeholder="Enter your search" /> <input type="submit" class="display-none" value="" /></form></aside><aside id="text-280634579" class="widget widget_text"><div class="textwidget"><p><strong>Co-Founders/Editors:</strong><br /> <a href="https://waitingfornextyear.com/author/scottsargent/">Scott Sargent</a> (<a href="http://www.twitter.com/wfnyscott" target="_blank" rel="noopener noreferrer">@WFNYScott</a>)<br /> <a href="https://waitingfornextyear.com/author/admin/">Andrew Schnitkey</a> (<a href="http://www.twitter.com/rockwfny" target="_blank" rel="noopener noreferrer">@RockWFNY</a>)</p><p><strong>Associate Editors:</strong><br /> <a href="https://waitingfornextyear.com/author/mgbode/">Michael Bode</a> (<a href="http://www.twitter.com/mgbode_WFNY" target="_blank" rel="noopener noreferrer">@mgbode_WFNY</a>)<br /> <a href="https://waitingfornextyear.com/author/jgerberrry/">Joe Gerberry</a> (<a href="http://twitter.com/thegerbswfny" target=_blank">@TheGerbsWFNY</a>)</p><p><strong>Podcast Hosts:</strong><br /> <a href="https://waitingfornextyear.com/author/craig/">Craig Lyndall</a> <a href="http://www.twitter.com/wfnycraig" target="_blank" rel="noopener noreferrer">(@WFNYCraig</a>)<br /> <a href="https://waitingfornextyear.com/author/dimoko/">Dave Sterling</a> <a href="http://www.twitter.com/dimoko" target="_blank" rel="noopener noreferrer">(@dimoko</a>)<br /> <a href="https://waitingfornextyear.com/author/tvalentino">Tom Valentino</a> (<a href="twitter.com/1tomvalentino" target=_blank">@1TomValentino</a></p><p><strong>Contributors:</strong><br /> <a href="https://waitingfornextyear.com/author/coreybarnes/">Corey Barnes</a> (<a href="http://www.twitter.com/Corey_Barnes" target="_blank" rel="noopener noreferrer">@Corey_Barnes</a>)<br /> <a href="https://twitter.com/jake_burns18" target="_blank" rel="noopener noreferrer">Jake Burns</a> (<a href="https://twitter.com/jake_burns18" target="_blank" rel="noopener noreferrer">@jake_burns18</a>)<br /> <a href="https://twitter.com/JayTCannon" target="_blank" rel="noopener noreferrer">Jay Cannon</a> (<a href="https://twitter.com/JayTCannon" target="_blank" rel="noopener noreferrer">@JayTCannon</a>)<br /> <a href="https://twitter.com/thejaketakeblog" target="_blank" rel="noopener noreferrer">Chuck Chura</a> (<a href="https://twitter.com/thejaketakeblog" target="_blank" rel="noopener noreferrer">@thejaketakeblog</a>)<br /> <a href="https://twitter.com/JCozmo" target="_blank" rel="noopener noreferrer">John Colosimo</a> (<a href="https://twitter.com/JCozmo" target="_blank" rel="noopener noreferrer">@JCozmo</a>)<br /> <a href="https://waitingfornextyear.com/author/joeyvgil/">Joe Gilbert</a> (<a href="http://www.twitter.com/JoeGilbertWFNY" target="_blank" rel="noopener noreferrer">@JoeGilbertWFNY</a>)<br /> <a href="https://www.twitter.com/mlkrall" target="_blank" rel="noopener noreferrer">Mitchell Krall</a> (<a href="https://www.twitter.com/mlkrall" target="_blank" rel="noopener noreferrer">@mlkrall</a>)<br /> <a href="https://waitingfornextyear.com/author/jnomina/">Jeff Nomina</a> (<a href="http://www.twitter.com/SportsNom" target="_blank" rel="noopener noreferrer">@SportsNom</a>)<br /> <a href="https://twitter.com/TimROConnor">Tim O'Connor</a> (<a href="https://twitter.com/TimROConnor" target="_blank" rel="noopener noreferrer">@TimROConnor</a>)<br /> <a href="https://waitingfornextyear.com/author/jpete/">Jim Pete</a> (<a href="http://www.twitter.com/jimpeteehc" target="_blank" rel="noopener noreferrer">@JimPeteEHC</a>)<br /> <a href="https://waitingfornextyear.com/author/josh/">Josh Poloha</a> (<a href="https://twitter.com/jorshP" target="_blank" rel="noopener noreferrer">@JorshP</a>)<br /> <a href="https://www.twitter.com/sports7765" target="_blank" rel="noopener noreferrer">Frank Ryan</a> (<a href="https://www.twitter.com/sports7765" target="_blank" rel="noopener noreferrer">@sports7765</a>)</p><p><strong>Co-Founder Emeritus:</strong><br /> <a href="https://waitingfornextyear.com/author/rickg15/">Rick Grayshock</a> (<a href="http://www.twitter.com/rickgrayshock" target="_blank" rel="noopener noreferrer">@RickGrayshock</a>)</p><p><strong>Editors Emeritus:</strong><br /> <a href="https://waitingfornextyear.com/author/clayman">Andrew Clayman</a> (<a href="http://twitter.com/claymanwfny" target=_blank">@ClaymanWFNY</a>)<br /> <a href="https://waitingfornextyear.com/author/td/">TD Dery</a> (<a href="http://twitter.com/td1tribeku" target=_blank">@TD1TribeKU</a>)<br /> <a href="https://waitingfornextyear.com/author/willgibson/">Will Gibson</a> (<a href="http://twitter.com.com/wjcgibson" target=_blank">@wjcgibson</a>)<br /> <a href="https://waitingfornextyear.com/author/mhattery/">Mike Hattery</a> (<a href="http://www.twitter.com/snarkyhatman" target="_blank" rel="noopener noreferrer">@snarkyhatman</a>)<br /> <a href="https://waitingfornextyear.com/author/denny/">Denny Mayo</a> (<a href="http://www.twitter.com/dennymayo" target="_blank" rel="noopener noreferrer">@DennyMayo</a>)<br /> <a href="https://waitingfornextyear.com/author/dparker">Dan Parker</a> (<a href="http://www.twitter.com/dp_cannon" target="_blank" rel="noopener noreferrer">@DP_Cannon</a>)<br /> <a href="https://waitingfornextyear.com/author/brendan/">Brendan Porath</a> (<a href="http://twitter.com/brendanporath" target=_blank">@BrendanPorath</a>)<br /> <a href="https://waitingfornextyear.com/author/jacob/">Jacob Rosen</a> (<a href="http://www.twitter.com/wfnyjacob" target="_blank" rel="noopener noreferrer">@WFNYJacob</a>)<br /> <a href="https://waitingfornextyear.com/author/jsteiner/">Jon Steiner</a> (<a href="http://www.twitter.com/nowimjon" target="_blank" rel="noopener noreferrer">@NowImJon</a>)<br /> <a href="https://waitingfornextyear.com/author/kylewelch/">Kyle Welch</a> (<a href="http://www.twitter.com/kcwelch330" target="_blank" rel="noopener noreferrer">@kcwelch330</a>)<br /> <a href="https://waitingfornextyear.com/author/gwill">Gage Will</a> (<a href="http://twitter.com/gagewfny" target=_blank">@GageWFNY</a>)</p></div></aside></div><div class="column one-third"><aside id="rss-3" class="widget widget_rss"><h4><a class="rsswidget" href="http://wfnypod.libsyn.com/rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waitingfornext-a.akamaihd.net/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://wfnypod.libsyn.com/">WFNY Podcasts</a></h4><ul><li><a class='rsswidget' href='http://wfnypod.libsyn.com/browns-fans-are-too-low-on-baker-now'>Browns fans are too low on Baker now</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/zack-meisel-joins-the-dery-bros'>Zack Meisel Joins the Dery Bros</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/on-the-2020-tribe-and-the-infamous-bug-game-0'>On the 2020 Tribe and the Infamous Bug Game</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/on-the-2020-tribe-and-the-infamous-bug-game'>On the 2020 Tribe and the Infamous Bug Game</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/spenser-confidential-and-the-master-the-viral-movie-podcast'>Spenser Confidential and The Master - The Viral Movie Podcast</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/tribe-world-series-games-6-and-7-with-the-dery-bros'>Tribe World Series Games 6, and 7 with the Dery Bros</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/more-quarantine-tribe-talk-with-the-dery-bros'>More Quarantine Tribe talk with the Dery Bros</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/okpants-quarantine-check-in'>okPANTS Quarantine Check-In</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/on-the-cannabis-business-and-cleveland-scene-with-eric-sandy'>On the Cannabis Business and Cleveland Scene with Eric Sandy</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/tribe-nostalgia-from-the-dery-brothers'>Tribe Nostalgia from the Dery Brothers</a></li></ul></aside><aside id="nav_menu-3" class="widget widget_nav_menu"><h4>WFNY Links</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-127682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127682"><a href="https://waitingfornextyear.com/wfny-opportunities/">WFNY Opportunities</a></li><li id="menu-item-127683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-127683"><a href="https://waitingfornextyear.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-127684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127684"><a href="https://waitingfornextyear.com/before-you-comment/">Before You Comment</a></li><li id="menu-item-127685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127685"><a href="https://waitingfornextyear.com/about/">About</a></li><li id="menu-item-127686" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127686"><a href="https://www.facebook.com/waitingfornextyear">WFNY Facebook Page</a></li><li id="menu-item-127687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127687"><a href="http://www.tiqiq.com/wfny/cleveland-tickets">WFNY Tickets</a></li></ul></div></aside></div><div class="column one-third"><aside id="rss-5" class="widget widget_rss"><h4><a class="rsswidget" href="http://wfny.disqus.com/latest.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waitingfornext-a.akamaihd.net/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://wfny.disqus.com/">RECENT COMMENTS</a></h4><ul><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/05/browns-2020-schedule-past-present-history/#comment-4915358813'>Re: The Past vs. the Future: 2020 Cleveland Browns’ Opponents</a><div class="rssSummary">I&#039;ll have to look a the tape.</div> <cite>MartyDaVille</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/05/joe-burrow-vs-baker-mayfield-is-a-victim-of-circumstance-competition/#comment-4915286981'>Re: Joe Burrow vs. Baker Mayfield is a Victim of Circumstance Competition</a><div class="rssSummary">Mayfield&#039;s lack of maturity gives the tie-breaker to Burrow.By a lot.BTW, how about that DeAndre Baker-Quinton Dunbar story? Man, that&#039;s almost literally unbelievable.</div> <cite>MartyDaVille</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/05/browns-2020-schedule-past-present-history/#comment-4915286062'>Re: The Past vs. the Future: 2020 Cleveland Browns’ Opponents</a><div class="rssSummary">Fine. But if you don&#039;t give me those tix, you don&#039;t matter. [is this how you play?]</div> <cite>Harv</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/05/joe-burrow-vs-baker-mayfield-is-a-victim-of-circumstance-competition/#comment-4915284526'>Re: Joe Burrow vs. Baker Mayfield is a Victim of Circumstance Competition</a><div class="rssSummary">Stronger arm. Both a;pear accurate based on their college reps. Many scouts claim Burrow’s arm is average for the league</div> <cite>tsm</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/05/browns-2020-schedule-past-present-history/#comment-4915277699'>Re: The Past vs. the Future: 2020 Cleveland Browns’ Opponents</a><div class="rssSummary">https://uploads.disquscdn.c...</div> <cite>MartyDaVille</cite></li></ul></aside></div></div></div><div class="footer_copy"><div class="container"><div class="column one"> <a id="back_to_top" class="button button_js" href=""><i class="icon-up-open-big"></i></a><div class="copyright"> © 2008-<script>document.write(new Date().getFullYear());</script> Waiting for Next Year, LLC<br/>Thanks to <a href="https://shoutitoutdesign.com" target="_blank" rel="nofollow">Shout It Out Design</a></div><ul class="social"></ul></div></div></div></footer></div>  <script type='text/javascript'>/* <![CDATA[ */ r3f5x9JS=escape(document['referrer']);
hf4N='466055a2e8b74dab823eb0023cfeb4f7';
hf4V='dccfdc7f83f447bf1f675bf6a94baf70';
cm4S="form[action='https://waitingfornextyear.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});}); /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var countVars = {"disqusShortname":"wfny"}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/plugins/disqus-comment-system/public/js/comment_count-3.0.17.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"211956 https:\/\/waitingfornextyear.com\/?p=211956","disqusShortname":"wfny","disqusTitle":"Have Browns Fans Gotten too Low on Baker Mayfield?","disqusUrl":"https:\/\/waitingfornextyear.com\/2020\/05\/have-browns-fans-gotten-to-low-on-baker-mayfield\/","postId":"211956"}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/plugins/disqus-comment-system/public/js/comment_embed-3.0.17.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/core.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/widget.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/mouse.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/sortable.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/tabs.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/accordion.min-1.11.4.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var mfn = {"mobileInit":"960","parallax":"translate3d","responsive":"1","sidebarSticky":"","lightbox":{"disable":false,"disableMobile":false,"title":false},"slider":{"blog":0,"clients":0,"offer":0,"portfolio":0,"shop":0,"slider":0,"testimonials":0}}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/plugins-21.6.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/menu-21.6.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/animations/animations.min-21.6.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/jplayer/jplayer.min-21.6.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/parallax/translate3d-21.6.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/scripts-21.6.1.js'></script> <script type='text/javascript'>.header-magazine #Top_bar .banner_wrapper { width: 720px !important; height: 90px !important; }
.header-magazine #Top_bar .banner_wrapper img { max-height: 90px !important; }</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js'></script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1589605491 -->