<!DOCTYPE html><html lang="en-US" class="no-js" itemscope itemtype="https://schema.org/Article"><head><meta charset="UTF-8" /> <script data-ad-client="ca-pub-5266060762538651" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><title>Breaking down the Cleveland Browns&#039; 2020 NFL Draft | Waiting For Next Year</title><meta name="format-detection" content="telephone=no"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><link rel="shortcut icon" href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny2.png" type="image/x-icon" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//waitingfornext-a.akamaihd.net' /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Feed" href="https://waitingfornextyear.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Comments Feed" href="https://waitingfornextyear.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Breaking down the Cleveland Browns&#8217; 2020 NFL Draft Comments Feed" href="https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://waitingfornextyear.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wpt-twitter-feed-css' href='https://waitingfornextyear.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' /><link rel='stylesheet' id='style-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/style-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-base-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/base-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-layout-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/layout-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-shortcodes-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/shortcodes-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-animations-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/animations/animations.min-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-jquery-ui-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/ui/jquery.ui.all-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-jplayer-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/jplayer/css/jplayer.blue.monday-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-responsive-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/responsive-21.6.0.1.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-fonts-css' href='https://fonts.googleapis.com/css?family=Hind+Madurai%3A1%2C400%2C500%2C700%7CUbuntu%3A1%2C400%2C500%2C700%7CPatua+One%3A1%2C400%2C500%2C700&#038;ver=5.4' type='text/css' media='all' /><style id='mfn-dynamic-inline-css' type='text/css'>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</style><style id='mfn-custom-inline-css' type='text/css'>.footer-copy-center #Footer .footer_copy .copyright{font-size:12px;line-height:16px}.post-footer{display:none}</style><link rel='stylesheet' id='wdfb_style-css' href='https://waitingfornextyear.com/wp-content/plugins/wpmu-dev-facebook/css/wdfb.css' type='text/css' media='all' /> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js'></script> <link rel='https://api.w.org/' href='https://waitingfornextyear.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://waitingfornextyear.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://waitingfornextyear.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='An Ohio State-heavy NFL Draft&#8230;again' href='https://waitingfornextyear.com/2020/04/ohio-state-buckeyes-2020-nfl-draft-10-selections-picks/' /><link rel='next' title='Meet the Mockers' href='https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/' /><meta name="generator" content="WordPress 5.4" /><link rel='shortlink' href='https://waitingfornextyear.com/?p=211806' /><meta property="fb:pages" content="20512657575" /><meta property="ia:markup_url" content="https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/?ia_markup=1" /><link type="text/css" rel="stylesheet" href="https://waitingfornextyear.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="@WFNYCLE" /><meta name="twitter:creator" content="@iggybrowns" /><meta name="twitter:url" content="https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/" /><meta name="twitter:title" content="Breaking down the Cleveland Browns&#8217; 2020 NFL Draft" /><meta name="twitter:description" content="WFNY&#039;s Joe Gilbert breaks down his views on the Cleveland Browns&#039; 2020 NFL Draft." /><meta name="twitter:image" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/02/Jedrick-Wills.jpg" /> <style type="text/css">ol.footnotes li{list-style-type:decimal}</style><link rel="canonical" href="https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/" /><meta name="description" content="WFNY&#039;s Joe Gilbert breaks down his views on the Cleveland Browns&#039; 2020 NFL Draft." />  <script type="text/javascript">var _wdfb_ajaxurl="https://waitingfornextyear.com/wp-admin/admin-ajax.php";var _wdfb_root_url="https://waitingfornextyear.com/wp-content/plugins/wpmu-dev-facebook";</script><meta property='fb:app_id' content='106265117682' /><meta property='og:type' content='article' /><meta property='og:title' content='Breaking down the Cleveland Browns&#039; 2020 NFL Draft' /><meta property='og:url' content='https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/' /><meta property='og:site_name' content='Waiting For Next Year' /><meta property='og:description' content='WFNY&#039;s Joe Gilbert breaks down his views on the Cleveland Browns&#039; 2020 NFL Draft.' /><meta property='og:image' content='https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/02/Jedrick-Wills-1024x576.jpg' />  <script type="text/javascript">( function( i, s, o, g, r, a, m ) {
		i[ 'GoogleAnalyticsObject' ] = r;
		i[ r ] = i[ r ] || function() {
			( i[ r ].q = i[ r ].q || [] ).push( arguments )
		}, i[ r ].l = 1 * new Date();
		a = s.createElement( o ),
			m = s.getElementsByTagName( o )[ 0 ];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore( a, m )
	} )( window, document, 'script', 'https://waitingfornextyear.com/wp-content/cache/busting/google-tracking/ga-af5c617d36e28d19710b882a6824e213.js', 'beehive_ga' );

	function beehive_ga_track() {
							beehive_ga( 'create', 'UA-36605884-1', 'auto', { 'name': 'single' } ); // Create single site tracking.
												beehive_ga( 'single.send', 'pageview' ); // Send pageview.
			}

			beehive_ga_track(); // Load tracking.</script> <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-211806 single-format-standard with_aside aside_right color-custom style-default button-default layout-full-width if-disable if-border-hide hide-love no-shadows header-stack header-magazine minimalist-header sticky-header sticky-white ab-hide subheader-title-left menu-line-below-80-1 menuo-no-borders footer-copy-center boxed2fw mobile-tb-center mobile-mini-mr-ll mobile-header-mini be-reg-21601 wpb-js-composer js-comp-ver-6.1 vc_responsive"><div id="fb-root"></div> <script async defer src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=449813798444257&autoLogAppEvents=1"></script><div id="Wrapper"><div id="Header_wrapper" class="" ><header id="Header"><div class="header_placeholder"></div><div id="Top_bar" class="loading"><div class="container"><div class="column one"><div class="top_bar_left clearfix"><div class="logo"><a id="logo" href="https://waitingfornextyear.com" title="Waiting For Next Year" data-height="60" data-padding="10"><img class="logo-main scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /><img class="logo-sticky scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-dark.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-dark-2x.png" data-height="99" alt="wfny-logo-dark" data-no-retina /><img class="logo-mobile scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /><img class="logo-mobile-sticky scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /></a></div><div class="menu_wrapper"><nav id="menu"><ul id="menu-main-menu-2" class="menu menu-main"><li id="menu-item-204199" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-indians-archive/"><span>Indians</span></a></li><li id="menu-item-204205" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-browns-archive/"><span>Browns</span></a></li><li id="menu-item-204204" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-cavs-archive/"><span>Cavs</span></a></li><li id="menu-item-204254" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/ohio-state-buckeyes-archive/"><span>Buckeyes</span></a></li><li id="menu-item-127673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#"><span>Other Sports</span></a><ul class="sub-menu"><li id="menu-item-204266" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/college-sports-archive/"><span>College Sports</span></a></li><li id="menu-item-204265" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/minor-league-baseball-archive/"><span>Minor League Baseball</span></a></li><li id="menu-item-204264" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/other-sports-archive/"><span>Other Sports</span></a></li></ul></li><li id="menu-item-204263" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/podcast-archive/"><span>Podcast</span></a></li></ul></nav><a class="responsive-menu-toggle " href="#"><i class="icon-menu-fine"></i></a></div><div class="secondary_menu_wrapper"></div><div class="banner_wrapper"> <ins class="adsbygoogle" style="width:468px;height:60px" data-ad-client="ca-pub-5266060762538651" data-ad-slot="6641400053"></ins></div><div class="search_wrapper"><form method="get" id="searchform" action="https://waitingfornextyear.com/"> <i class="icon_search icon-search-fine"></i> <a href="#" class="icon_close"><i class="icon-cancel-fine"></i></a> <input type="text" class="field" name="s" placeholder="Enter your search" /> <input type="submit" class="display-none" value="" /></form></div></div></div></div></div></header><div id="Subheader"><div class="container"><div class="column one"><h1 class="title">Breaking down the Cleveland Browns&#8217; 2020 NFL Draft</h1></div></div></div></div><div id="Content"><div class="content_wrapper clearfix"><div class="sections_group"><div id="post-211806" class="no-title no-share share-simple post-211806 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft tag-2020-nfl-draft tag-browns tag-donovan-peoples-jones tag-grant-delpit tag-harrison-bryant tag-jacob-phillips tag-jedrick-wills-jr tag-jordan-elliott tag-nick-harris"> <a class="fixed-nav fixed-nav-prev format- style-arrows" href="https://waitingfornextyear.com/2020/04/ohio-state-buckeyes-2020-nfl-draft-10-selections-picks/"><span class="arrow"><i class="icon-left-open-big"></i></span><div class="photo"><img width="80" height="80" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Young-Okudah-80x80.jpg" class="attachment-blog-navi size-blog-navi wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Young-Okudah-80x80.jpg 80w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Young-Okudah-150x150.jpg 150w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Young-Okudah-85x85.jpg 85w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Young-Okudah-45x45.jpg 45w" sizes="(max-width: 80px) 100vw, 80px" /></div><div class="desc"><h6>An Ohio State-heavy NFL Draft&#8230;again</h6><span class="date"><i class="icon-clock"></i>April 27, 2020</span></div></a><a class="fixed-nav fixed-nav-next format- style-arrows" href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/"><span class="arrow"><i class="icon-right-open-big"></i></span><div class="photo"><img width="80" height="80" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-80x80.jpg" class="attachment-blog-navi size-blog-navi wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-80x80.jpg 80w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-150x150.jpg 150w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-85x85.jpg 85w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-45x45.jpg 45w" sizes="(max-width: 80px) 100vw, 80px" /></div><div class="desc"><h6>Meet the Mockers</h6><span class="date"><i class="icon-clock"></i>April 28, 2020</span></div></a><div class="section section-post-header"><div class="section_wrapper clearfix"><div class="column one post-header"><div class="title_wrapper"><div class="post-meta clearfix"><div class="author-date"> <span class="vcard author post-author" itemprop="author" itemscope itemtype="https://schema.org/Person"> <span class="label">Published by</span> <i class="icon-user"></i> <span class="fn" itemprop="name"><a href="https://waitingfornextyear.com/author/joeyvgil/">Joe Gilbert</a></span> </span> <span class="date"> <span class="label">on</span> <i class="icon-clock"></i> <time class="entry-date updated" datetime="2020-04-28T08:55:19-04:00" itemprop="datePublished" >April 28, 2020</time><meta itemprop="dateModified" content="2020-04-28T08:55:19-04:00"/> </span><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization" style="display:none;"><meta itemprop="name" content="Waiting For Next Year"/><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" itemprop="url" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png"/></div></div></div></div></div></div><div class="column one single-photo-wrapper image"><div class="image_frame scale-with-grid "><div class="image_wrapper"> <a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/02/Jedrick-Wills-1024x576.jpg" rel="prettyphoto"><div class="mask"></div><div itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><img width="1200" height="480" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/02/Jedrick-Wills-1200x480.jpg" class="scale-with-grid wp-post-image" alt="" /><meta itemprop="url" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/02/Jedrick-Wills.jpg"/><meta itemprop="width" content="1796"/><meta itemprop="height" content="1010"/></div></a><div class="image_links"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/02/Jedrick-Wills-1024x576.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a></div></div><p class="wp-caption-text hide">Alabama athletics</p></div></div></div></div><div class="post-wrapper-content"><div class="section the_content has_content"><div class="section_wrapper"><div class="the_content_wrapper"><div class="wdfb_like_button"><fb:like href="https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/" send="true" layout="button_count" width="450" colorscheme="light" show_faces="true" font=""></fb:like></div><p>The 2020 NFL Draft was a different experience this year with it all being virtual. However, it went off without a hitch. The Cleveland Browns were very busy during the three-day event. The team made two trades, picked up a future draft pick, and selected seven players over the course of the seven rounds. In the first round, the Browns selected <a href="https://waitingfornextyear.com/2020/04/browns-select-jedrick-wills-no-10-2020-nfl-draft/">offensive tackle Jedrick Wills Jr.</a> of Alabama. In the second round, Cleveland added <a href="https://waitingfornextyear.com/2020/04/browns-select-grant-delpit-no-41-2020-nfl-draft/">safety Grant Delpit</a> of LSU. The Browns had two third-round picks, selecting <a href="https://waitingfornextyear.com/2020/04/browns-select-jordan-elliott-no-88-2020-nfl-draft/">interior defensive lineman Jordan Elliott</a> and <a href="https://waitingfornextyear.com/2020/04/browns-select-jacob-phillips-2020-nfl-draft/">linebacker Jacob Phillips</a>. In the fourth round, the Browns drafted <a href="https://waitingfornextyear.com/2020/04/browns-select-tight-end-harrison-bryant-pick-no-115-2020-nfl-draft/">tight end Harrison Bryant</a> of Florida Atlantic. The fifth round saw the Browns take <a href="https://waitingfornextyear.com/2020/04/browns-select-center-nick-harris-2020-nfl-draft/">center Nick Harris</a> of Washington. And, to finish up their draft, Cleveland added <a href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/">wide receiver Donovan Peoples-Jones</a> of Michigan with their seventh and final pick of the draft in the sixth round.</p><p>It was a fun three days with the Browns adding some much-needed talent at positions of need. So, how did they do? Well, here is my breakdown of the Browns 2020 NFL Draft. Check back over the course of the next many weeks as I examine the film of the Browns’ seven new draftees.</p><p><strong><u>Draft Pick 2020 Outlook</u></strong></p><p><strong>OT Jedrick Wills Jr.:</strong> Starting Left Tackle</p><div class="SYDHoyDk" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-5266060762538651" data-ad-slot="2849801225"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>S Grant Delpit:</strong> Starting Free Safety</p><p><strong>IDL Jordan Elliott:</strong> Rotational Interior Defensive Lineman</p><p><strong>LB Jacob Phillips:</strong> Defensive Role Player/Special Teams Coverage Contributor</p><p><strong>TE Harrison Bryant:</strong> Rotational Tight End</p><p><strong>C Nick Harris:</strong> Interior Offensive Line Backup</p><p><strong>WR Donovan Peoples-Jones:</strong> Developmental Receiver/Special Teams Returner Contributor</p><p><strong>Favorite pick: OT Jedrick Wills Jr.</strong><strong> </strong></p><p>I love this selection. The value and need met perfectly here. The Browns’ biggest hole on the roster was left tackle. Jedrick Wills was my No. 1 offensive tackle prospect and the No. 6 overall player on my big board. He will slide right into the left tackle spot and fortify the offensive line in front of Baker Mayfield. Wills has a great skill set to fit in Kevin Stefanski’s zone-blocking scheme. He has a great combination of movement skills, feet, and techniques that I believe will be perfect for the scheme. He is the best pass blocker in the draft class, in my opinion. His strength will also be a strong presence in the run blocking game.</p><p><strong>Pick I would have gone in a different direction: LB Jacob Phillips</strong></p><p>I am not totally opposed to this pick, because I do like Jacob Phillips strong tackling ability and run defending ability. But, I would have gone in a direction with this pick in the third round. First of all, there were a few linebackers I liked better in that spot, including Malik Harrison of Ohio State, Akeem Davis-Gaither of Appalachian State, and Troy Dye of Oregon. I also was looking at K’Von Wallace or Amik Robertson to address the nickelback position on the defense. All in all, in the past I have really disliked picks, but this season I understood pretty much all of them, but with this pick, I would have just gone in another direction.<strong> </strong></p><p><strong>Pick I need to study more: TE Harrison Bryant</strong></p><p>I really want to watch more film on Harrison Bryant. I liked Brycen Hopkins of Purdue a lot, ranking him as my No. 2 rated tight end. He was still on the board when they made this pick. However, I like what I see with Bryant and this class of tight ends was really close in my eyes, which not much separation between the seven or so. The way the Browns glowingly talked about Bryant and how they were really surprised he was still there makes me want to watch more of Bryant and how he fits on the Browns roster.</p><p><strong>Best under-the-radar pick: IDL Jordan Elliott</strong></p><p>Elliott could be a highly productive player this coming season given his talent and the lack of depth in the interior of the defensive line. He was my sixth-ranked interior defensive lineman and just missed my top 50 Big Board. Elliott is an athletic interior defensive lineman. He shows a really good combination of power and explosion to really shock blockers. He can win with his hands, beating blockers with his powerful hands. He has a lot of upside to be a disruptive starter on the defensive line with more experience and playing time.</p><p><strong>Biggest instant impact: OT Jedrick Wills Jr.</strong></p><p>Jedrick Wills will immediately start at left tackle with the talent to be very successful right away. He is the draftee with most ready to play skill set. He fits well in the Browns’ new zone-blocking scheme. His pass blocking and technique are already on a high level, while his strength will be a positive plus in the run game. Wills is ready to go and fortify the Browns offensive line from Day 1.</p><p><strong>Best late-round value: WR Donovan Peoples-Jones</strong><strong> </strong></p><p>Donovan Peoples-Jones has the athletic profile that few receivers have, including the ones taken before him in the draft. His production at Michigan is what caused him to fall. However, the quarterback play that he had to deal with has to be accounted for in lack of production. He has shown glimpses of great play where his true talent shows. Picking a player with this athletic profile in the sixth round is well worth the pick.</p><p><strong>Biggest special teams contributor: WR Donovan Peoples-Jones</strong></p><p>Donovan Peoples-Jones was a three-year starter as a punt returner. He was very successful as a punter returner, averaging 8.3 yards per return over his three seasons as a returner, while also pulling off two touchdown returns in his career. He uses his elite athleticism to be able to make plays in the return game. He has the talent to be the starting punt returner from Day 1.</p><p><strong>Biggest need area filled: Offensive Tackle</strong></p><p>The Browns’ biggest hole on the roster was at offensive tackle, specifically at left tackle. So, the Browns utilized their first-round pick to address this hole with the No. 1 offensive tackle in the class. Wills should be able to immediately start at left tackle, all but eliminating the need from the roster. The position has two strong starters and two able backups. It is in a really strong place.</p><p><strong>Biggest need not filled: Edge Rusher</strong></p><p>The Browns were not able to add any edge rushers in the class. The depth is the problem at edge rusher. Cleveland has an elite rusher in Myles Garrett and a really good starter next to him in Olivier Vernon. They also have one strong rotational rusher in Adrian Clayborn. But, beyond that, the edge rusher unit is barren. The team could use one more rotational rusher to add to this group of three because if this unit suffers an injury, it will be left with no reliable backups. Depth is needed here.</p><div class="wdfb_like_button"><fb:like href="https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/" send="true" layout="button_count" width="450" colorscheme="light" show_faces="true" font=""></fb:like></div></div></div></div><div class="section section-post-footer"><div class="section_wrapper clearfix"><div class="column one post-pager"></div></div></div><div class="section section-post-about"><div class="section_wrapper clearfix"></div></div></div><div class="section section-post-related"><div class="section_wrapper clearfix"><div class="section-related-adjustment "><h4>Related posts</h4><div class="section-related-ul col-3"><div class="column post-related post-211809 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft tag-2020-nfl-draft tag-2020-nfl-mock-draft tag-nfl-draft tag-nfl-mock-draft"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/"><div class="mask"></div><img width="960" height="750" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-960x750.jpg" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-960x750.jpg 960w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-1280x1000.jpg 1280w" sizes="(max-width: 960px) 100vw, 960px" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-1024x576.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/" class="link"><i class="icon-link"></i></a></div></div></div></div><div class="date_label">April 28, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/">Meet the Mockers</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div><div class="column post-related post-211617 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft category-www-2 tag-2020-nfl-draft tag-browns tag-donovan-peoples-jones tag-grant-delpit tag-harrison-bryant tag-jacob-phillips tag-jedrick-wills tag-jedrick-wills-jr tag-jordan-elliott tag-nick-harris"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/04/2020-nfl-draft-cleveland-browns-grades/"><div class="mask"></div><img width="960" height="750" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Wills-Cartoon-Crop-960x750.png" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Wills-Cartoon-Crop-960x750.png 960w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Wills-Cartoon-Crop-1280x1000.png 1280w" sizes="(max-width: 960px) 100vw, 960px" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Wills-Cartoon-Crop-1024x698.png" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/04/2020-nfl-draft-cleveland-browns-grades/" class="link"><i class="icon-link"></i></a></div></div></div></div><div class="date_label">April 27, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/04/2020-nfl-draft-cleveland-browns-grades/">2020 NFL Draft: Categorical, ridiculous grades for the Browns</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/04/2020-nfl-draft-cleveland-browns-grades/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div><div class="column post-related post-211774 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft tag-2020-nfl-draft tag-browns tag-donovan-peoples-jones"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/"><div class="mask"></div><img width="960" height="750" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/1075785318.jpg.0-960x750.jpg" class="scale-with-grid wp-post-image" alt="" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/1075785318.jpg.0-1024x683.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/" class="link"><i class="icon-link"></i></a></div></div><p class="wp-caption-text hide">Rich von Biberstein/Icon Sportswire via Getty Images</p></div></div><div class="date_label">April 25, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/">2020 NFL Draft: Browns select WR Donovan Peoples-Jones of Michigan at No. 187</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div></div></div></div></div><div class="section section-post-comments"><div class="section_wrapper clearfix"><div class="column one comments"><div id="disqus_thread"></div></div></div></div></div></div><div class="mcb-sidebar sidebar sidebar-1 four columns "><div class="widget-area"><div class="inner-wrapper-sticky clearfix"><aside id="custom_html-2" class="widget_text widget widget_custom_html"><h3>WANT TO SUPPORT WFNY?</h3><div class="textwidget custom-html-widget"><a href="http://patreon.com/wfny" target="_blank" rel="nofollow noopener noreferrer"><img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/09/become_a_patron_button.png"></a></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><h3>BUY WFNY GEAR!</h3><div class="textwidget custom-html-widget"><a href="http://wfny.threadless.com/" target="_blank" rel="nofollow noopener noreferrer"><img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2018/02/WFNYX-tshirt-sample.jpg"></a></div></aside><aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5266060762538651" data-ad-slot="7449450699" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><h3>WFNY PODCAST</h3><div class="textwidget custom-html-widget"><iframe style="border: none" src="//html5-player.libsyn.com/embed/destination/id/134539/height/500/theme/custom/thumbnail/yes/preload/no/direction/backward/no-cache/true/render-playlist/yes/custom-color/2e1094/" height="500" width="100%" scrolling="no" allowfullscreen webkitallowfullscreen mozallowfullscreen oallowfullscreen msallowfullscreen></iframe> <br><br> <a href="https://www.facebook.com/WFNYPod" target="_blank" rel="noopener noreferrer">The WFNY Podcast Facebook Page</a><br><br> <a href="https://itunes.apple.com/us/podcast/the-official-waiting-for-next-year-podcast/id569883258?mt=2" target="_blank" rel="noopener noreferrer">WFNY Podcast on iTunes</a></div></aside><aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="fb-page" data-href="https://www.facebook.com/waitingfornextyear/" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/waitingfornextyear/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/waitingfornextyear/">Waiting For Next Year - WFNY</a></blockquote></div></div></aside><style>.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type:none}.rpwe-block a{display:inline!important;text-decoration:none}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:14px!important;line-height:1.5em}.rpwe-thumb{border:1px solid #eee!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important}.rpwe-summary{font-size:12px}.rpwe-time{color:#bbb;font-size:11px}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px}.rpwe-alignleft{display:inline;float:left}.rpwe-alignright{display:inline;float:right}.rpwe-aligncenter{display:block;margin-left:auto;margin-right:auto}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table!important}.rpwe-clearfix:after{clear:both}.rpwe-clearfix{zoom:1}</style><aside id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h3>LOOK &#038; LISTEN</h3><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Meet-the-Fockers-45x45.jpg" alt="Meet the Mockers"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/mocking-the-mockers-2020-nfl-draft-mock/" title="Permalink to Meet the Mockers" rel="bookmark">Meet the Mockers</a></h3><time class="rpwe-time published" datetime="2020-04-28T09:55:46-04:00">April 28, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/ohio-state-buckeyes-2020-nfl-draft-10-selections-picks/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Young-Okudah-scaled-45x45.jpg" alt="An Ohio State-heavy NFL Draft&#8230;again"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/ohio-state-buckeyes-2020-nfl-draft-10-selections-picks/" title="Permalink to An Ohio State-heavy NFL Draft&#8230;again" rel="bookmark">An Ohio State-heavy NFL Draft&#8230;again</a></h3><time class="rpwe-time published" datetime="2020-04-27T09:55:47-04:00">April 27, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/2020-nfl-draft-cleveland-browns-grades/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Wills-Cartoon-Crop-45x45.png" alt="2020 NFL Draft: Categorical, ridiculous grades for the Browns"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/2020-nfl-draft-cleveland-browns-grades/" title="Permalink to 2020 NFL Draft: Categorical, ridiculous grades for the Browns" rel="bookmark">2020 NFL Draft: Categorical, ridiculous grades for the Browns</a></h3><time class="rpwe-time published" datetime="2020-04-27T08:55:11-04:00">April 27, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/1075785318.jpg.0-45x45.jpg" alt="2020 NFL Draft: Browns select WR Donovan Peoples-Jones of Michigan at No. 187"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-select-donovan-peoples-jones-2020-nfl-draft/" title="Permalink to 2020 NFL Draft: Browns select WR Donovan Peoples-Jones of Michigan at No. 187" rel="bookmark">2020 NFL Draft: Browns select WR Donovan Peoples-Jones of Michigan at No. 187</a></h3><time class="rpwe-time published" datetime="2020-04-25T16:22:06-04:00">April 25, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-select-center-nick-harris-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/O6E72CD6W5BZXFGBNS5DW6QL6U-45x45.jpg" alt="2020 NFL Draft: Browns select C Nick Harris of Washington at No. 160"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-select-center-nick-harris-2020-nfl-draft/" title="Permalink to 2020 NFL Draft: Browns select C Nick Harris of Washington at No. 160" rel="bookmark">2020 NFL Draft: Browns select C Nick Harris of Washington at No. 160</a></h3><time class="rpwe-time published" datetime="2020-04-25T15:08:43-04:00">April 25, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-select-tight-end-harrison-bryant-pick-no-115-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/191026_N_EP388_288-45x45.jpeg" alt="2020 NFL Draft: Browns select TE Harrison Bryant of FAU at No. 115"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-select-tight-end-harrison-bryant-pick-no-115-2020-nfl-draft/" title="Permalink to 2020 NFL Draft: Browns select TE Harrison Bryant of FAU at No. 115" rel="bookmark">2020 NFL Draft: Browns select TE Harrison Bryant of FAU at No. 115</a></h3><time class="rpwe-time published" datetime="2020-04-25T12:54:16-04:00">April 25, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-select-jacob-phillips-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/5d7eff7a4837b.image_-45x45.jpg" alt="2020 NFL Draft: Browns select LB Jacob Phillips of LSU at No. 97"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-select-jacob-phillips-2020-nfl-draft/" title="Permalink to 2020 NFL Draft: Browns select LB Jacob Phillips of LSU at No. 97" rel="bookmark">2020 NFL Draft: Browns select LB Jacob Phillips of LSU at No. 97</a></h3><time class="rpwe-time published" datetime="2020-04-24T23:58:01-04:00">April 24, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-select-jordan-elliott-no-88-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/IMG_2755-scaled-45x45.jpeg" alt="2020 NFL Draft: Browns select IDL Jordan Elliott of Missouri No. 88"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-select-jordan-elliott-no-88-2020-nfl-draft/" title="Permalink to 2020 NFL Draft: Browns select IDL Jordan Elliott of Missouri No. 88" rel="bookmark">2020 NFL Draft: Browns select IDL Jordan Elliott of Missouri No. 88</a></h3><time class="rpwe-time published" datetime="2020-04-24T23:22:15-04:00">April 24, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-select-grant-delpit-no-41-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Grant-Delpit-45x45.jpg" alt="2020 NFL Draft: Browns select S Grant Delpit of LSU at No. 44"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-select-grant-delpit-no-41-2020-nfl-draft/" title="Permalink to 2020 NFL Draft: Browns select S Grant Delpit of LSU at No. 44" rel="bookmark">2020 NFL Draft: Browns select S Grant Delpit of LSU at No. 44</a></h3><time class="rpwe-time published" datetime="2020-04-24T20:33:24-04:00">April 24, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/04/browns-jedrick-wills-jr-meet-the-prospect-2020-nfl-draft/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/04/Jedrick-Wills-45x45.jpg" alt="Meet the Prospect: OT Jedrick Wills Jr."></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/04/browns-jedrick-wills-jr-meet-the-prospect-2020-nfl-draft/" title="Permalink to Meet the Prospect: OT Jedrick Wills Jr." rel="bookmark">Meet the Prospect: OT Jedrick Wills Jr.</a></h3><time class="rpwe-time published" datetime="2020-04-24T14:15:27-04:00">April 24, 2020</time></li></ul></div></aside></div></div></div></div></div> <script type="text/javascript" src="https://connect.facebook.net/en_US/all.js"></script><div id='fb-root'></div><script type='text/javascript'>FB.init({
	            appId: '106265117682',
	            status: true,
	            cookie: true,
	            xfbml: true,
	            oauth: true
	         });</script> <footer id="Footer" class="clearfix"><div class="widgets_wrapper "><div class="container"><div class="column one-third"><aside id="search-3" class="widget widget_search"><form method="get" id="searchform" action="https://waitingfornextyear.com/"> <i class="icon_search icon-search-fine"></i> <a href="#" class="icon_close"><i class="icon-cancel-fine"></i></a> <input type="text" class="field" name="s" placeholder="Enter your search" /> <input type="submit" class="display-none" value="" /></form></aside><aside id="text-280634579" class="widget widget_text"><div class="textwidget"><p><strong>Co-Founders/Editors:</strong><br /> <a href="https://waitingfornextyear.com/author/scottsargent/">Scott Sargent</a> (<a href="http://www.twitter.com/wfnyscott" target="_blank" rel="noopener noreferrer">@WFNYScott</a>)<br /> <a href="https://waitingfornextyear.com/author/admin/">Andrew Schnitkey</a> (<a href="http://www.twitter.com/rockwfny" target="_blank" rel="noopener noreferrer">@RockWFNY</a>)</p><p><strong>Associate Editors:</strong><br /> <a href="https://waitingfornextyear.com/author/mgbode/">Michael Bode</a> (<a href="http://www.twitter.com/mgbode_WFNY" target="_blank" rel="noopener noreferrer">@mgbode_WFNY</a>)<br /> <a href="https://waitingfornextyear.com/author/jgerberrry/">Joe Gerberry</a> (<a href="http://twitter.com/thegerbswfny" target=_blank">@TheGerbsWFNY</a>)</p><p><strong>Podcast Hosts:</strong><br /> <a href="https://waitingfornextyear.com/author/craig/">Craig Lyndall</a> <a href="http://www.twitter.com/wfnycraig" target="_blank" rel="noopener noreferrer">(@WFNYCraig</a>)<br /> <a href="https://waitingfornextyear.com/author/dimoko/">Dave Sterling</a> <a href="http://www.twitter.com/dimoko" target="_blank" rel="noopener noreferrer">(@dimoko</a>)<br /> <a href="https://waitingfornextyear.com/author/tvalentino">Tom Valentino</a> (<a href="twitter.com/1tomvalentino" target=_blank">@1TomValentino</a></p><p><strong>Contributors:</strong><br /> <a href="https://waitingfornextyear.com/author/coreybarnes/">Corey Barnes</a> (<a href="http://www.twitter.com/Corey_Barnes" target="_blank" rel="noopener noreferrer">@Corey_Barnes</a>)<br /> <a href="https://twitter.com/jake_burns18" target="_blank" rel="noopener noreferrer">Jake Burns</a> (<a href="https://twitter.com/jake_burns18" target="_blank" rel="noopener noreferrer">@jake_burns18</a>)<br /> <a href="https://twitter.com/JayTCannon" target="_blank" rel="noopener noreferrer">Jay Cannon</a> (<a href="https://twitter.com/JayTCannon" target="_blank" rel="noopener noreferrer">@JayTCannon</a>)<br /> <a href="https://twitter.com/thejaketakeblog" target="_blank" rel="noopener noreferrer">Chuck Chura</a> (<a href="https://twitter.com/thejaketakeblog" target="_blank" rel="noopener noreferrer">@thejaketakeblog</a>)<br /> <a href="https://twitter.com/JCozmo" target="_blank" rel="noopener noreferrer">John Colosimo</a> (<a href="https://twitter.com/JCozmo" target="_blank" rel="noopener noreferrer">@JCozmo</a>)<br /> <a href="https://waitingfornextyear.com/author/joeyvgil/">Joe Gilbert</a> (<a href="http://www.twitter.com/JoeGilbertWFNY" target="_blank" rel="noopener noreferrer">@JoeGilbertWFNY</a>)<br /> <a href="https://www.twitter.com/mlkrall" target="_blank" rel="noopener noreferrer">Mitchell Krall</a> (<a href="https://www.twitter.com/mlkrall" target="_blank" rel="noopener noreferrer">@mlkrall</a>)<br /> <a href="https://waitingfornextyear.com/author/jnomina/">Jeff Nomina</a> (<a href="http://www.twitter.com/SportsNom" target="_blank" rel="noopener noreferrer">@SportsNom</a>)<br /> <a href="https://twitter.com/TimROConnor">Tim O'Connor</a> (<a href="https://twitter.com/TimROConnor" target="_blank" rel="noopener noreferrer">@TimROConnor</a>)<br /> <a href="https://waitingfornextyear.com/author/jpete/">Jim Pete</a> (<a href="http://www.twitter.com/jimpeteehc" target="_blank" rel="noopener noreferrer">@JimPeteEHC</a>)<br /> <a href="https://waitingfornextyear.com/author/josh/">Josh Poloha</a> (<a href="https://twitter.com/jorshP" target="_blank" rel="noopener noreferrer">@JorshP</a>)<br /> <a href="https://www.twitter.com/sports7765" target="_blank" rel="noopener noreferrer">Frank Ryan</a> (<a href="https://www.twitter.com/sports7765" target="_blank" rel="noopener noreferrer">@sports7765</a>)</p><p><strong>Co-Founder Emeritus:</strong><br /> <a href="https://waitingfornextyear.com/author/rickg15/">Rick Grayshock</a> (<a href="http://www.twitter.com/rickgrayshock" target="_blank" rel="noopener noreferrer">@RickGrayshock</a>)</p><p><strong>Editors Emeritus:</strong><br /> <a href="https://waitingfornextyear.com/author/clayman">Andrew Clayman</a> (<a href="http://twitter.com/claymanwfny" target=_blank">@ClaymanWFNY</a>)<br /> <a href="https://waitingfornextyear.com/author/td/">TD Dery</a> (<a href="http://twitter.com/td1tribeku" target=_blank">@TD1TribeKU</a>)<br /> <a href="https://waitingfornextyear.com/author/willgibson/">Will Gibson</a> (<a href="http://twitter.com.com/wjcgibson" target=_blank">@wjcgibson</a>)<br /> <a href="https://waitingfornextyear.com/author/mhattery/">Mike Hattery</a> (<a href="http://www.twitter.com/snarkyhatman" target="_blank" rel="noopener noreferrer">@snarkyhatman</a>)<br /> <a href="https://waitingfornextyear.com/author/denny/">Denny Mayo</a> (<a href="http://www.twitter.com/dennymayo" target="_blank" rel="noopener noreferrer">@DennyMayo</a>)<br /> <a href="https://waitingfornextyear.com/author/dparker">Dan Parker</a> (<a href="http://www.twitter.com/dp_cannon" target="_blank" rel="noopener noreferrer">@DP_Cannon</a>)<br /> <a href="https://waitingfornextyear.com/author/brendan/">Brendan Porath</a> (<a href="http://twitter.com/brendanporath" target=_blank">@BrendanPorath</a>)<br /> <a href="https://waitingfornextyear.com/author/jacob/">Jacob Rosen</a> (<a href="http://www.twitter.com/wfnyjacob" target="_blank" rel="noopener noreferrer">@WFNYJacob</a>)<br /> <a href="https://waitingfornextyear.com/author/jsteiner/">Jon Steiner</a> (<a href="http://www.twitter.com/nowimjon" target="_blank" rel="noopener noreferrer">@NowImJon</a>)<br /> <a href="https://waitingfornextyear.com/author/kylewelch/">Kyle Welch</a> (<a href="http://www.twitter.com/kcwelch330" target="_blank" rel="noopener noreferrer">@kcwelch330</a>)<br /> <a href="https://waitingfornextyear.com/author/gwill">Gage Will</a> (<a href="http://twitter.com/gagewfny" target=_blank">@GageWFNY</a>)</p></div></aside></div><div class="column one-third"><aside id="rss-3" class="widget widget_rss"><h4><a class="rsswidget" href="http://wfnypod.libsyn.com/rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waitingfornext-a.akamaihd.net/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://wfnypod.libsyn.com/">WFNY Podcasts</a></h4><ul><li><a class='rsswidget' href='http://wfnypod.libsyn.com/spenser-confidential-and-the-master-the-viral-movie-podcast'>Spenser Confidential and The Master - The Viral Movie Podcast</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/tribe-world-series-games-6-and-7-with-the-dery-bros'>Tribe World Series Games 6, and 7 with the Dery Bros</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/more-quarantine-tribe-talk-with-the-dery-bros'>More Quarantine Tribe talk with the Dery Bros</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/okpants-quarantine-check-in'>okPANTS Quarantine Check-In</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/on-the-cannabis-business-and-cleveland-scene-with-eric-sandy'>On the Cannabis Business and Cleveland Scene with Eric Sandy</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/tribe-nostalgia-from-the-dery-brothers'>Tribe Nostalgia from the Dery Brothers</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/catching-up-with-okpants-0'>Catching up with okpants</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/the-dery-brothers-tell-tribe-stories'>The Dery Brothers Tell Tribe Stories</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/watch-cliffhanger-and-take-steroids-chris-clem'>Watch Cliffhanger and Take Steroids - Chris Clem</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/covid-cancellations-lindor-talks-and-more'>COVID Cancellations, Lindor Talks, and More</a></li></ul></aside><aside id="nav_menu-3" class="widget widget_nav_menu"><h4>WFNY Links</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-127682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127682"><a href="https://waitingfornextyear.com/wfny-opportunities/">WFNY Opportunities</a></li><li id="menu-item-127683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-127683"><a href="https://waitingfornextyear.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-127684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127684"><a href="https://waitingfornextyear.com/before-you-comment/">Before You Comment</a></li><li id="menu-item-127685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127685"><a href="https://waitingfornextyear.com/about/">About</a></li><li id="menu-item-127686" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127686"><a href="https://www.facebook.com/waitingfornextyear">WFNY Facebook Page</a></li><li id="menu-item-127687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127687"><a href="http://www.tiqiq.com/wfny/cleveland-tickets">WFNY Tickets</a></li></ul></div></aside></div><div class="column one-third"><aside id="rss-5" class="widget widget_rss"><h4><a class="rsswidget" href="http://wfny.disqus.com/latest.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waitingfornext-a.akamaihd.net/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://wfny.disqus.com/">RECENT COMMENTS</a></h4><ul><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/#comment-4893501382'>Re: Breaking down the Cleveland Browns’ 2020 NFL Draft</a><div class="rssSummary">A team with zero pressure game experience, a rookie HC and brand new systems to learn better have a bigger window than 1-2 seasons before you risk losing core players. All the more so when this season&#039;s acclimation will be shortened by world events. The failed Freddie thing cost them precious cheap contract time.</div> <cite>Harv</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/#comment-4893420293'>Re: Breaking down the Cleveland Browns’ 2020 NFL Draft</a><div class="rssSummary">Say what you will but the Browns got abused in running situations last year and Clowney is stout against the run. That would be a significant upgrade to Vernon but it&#039;s not sexy to talk run defense. I&#039;m not even a Vernon hater.</div> <cite>scripty</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/#comment-4893417562'>Re: Breaking down the Cleveland Browns’ 2020 NFL Draft</a><div class="rssSummary">To me the best thing about draft weekend was Urban saying Peoples could have been a top 10 overall pick, just a tremendous knee-capping of TSUN.</div> <cite>scripty</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/#comment-4893415140'>Re: Breaking down the Cleveland Browns’ 2020 NFL Draft</a><div class="rssSummary">The window is now though, when half the team is on rookie deals. Not in 3 years when Baker and Garrett are max players.</div> <cite>scripty</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/04/browns-2020-nfl-draft-breakdown/#comment-4893414081'>Re: Breaking down the Cleveland Browns’ 2020 NFL Draft</a><div class="rssSummary">Baun is older and that&#039;s an analytics no no.</div> <cite>scripty</cite></li></ul></aside></div></div></div><div class="footer_copy"><div class="container"><div class="column one"> <a id="back_to_top" class="button button_js" href=""><i class="icon-up-open-big"></i></a><div class="copyright"> © 2008-<script>document.write(new Date().getFullYear());</script> Waiting for Next Year, LLC<br/>Thanks to <a href="https://shoutitoutdesign.com" target="_blank" rel="nofollow">Shout It Out Design</a></div><ul class="social"></ul></div></div></div></footer></div>  <script type='text/javascript'>/* <![CDATA[ */ r3f5x9JS=escape(document['referrer']);
hf4N='6c488504dcdb319dc13919b9b7829b0d';
hf4V='0b3eaa25b573285c4905674b17ec117b';
cm4S="form[action='https://waitingfornextyear.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});}); /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var countVars = {"disqusShortname":"wfny"}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/plugins/disqus-comment-system/public/js/comment_count-3.0.17.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"211806 https:\/\/waitingfornextyear.com\/?p=211806","disqusShortname":"wfny","disqusTitle":"Breaking down the Cleveland Browns\u2019 2020 NFL Draft","disqusUrl":"https:\/\/waitingfornextyear.com\/2020\/04\/browns-2020-nfl-draft-breakdown\/","postId":"211806"}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/plugins/disqus-comment-system/public/js/comment_embed-3.0.17.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/core.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/widget.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/mouse.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/sortable.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/tabs.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/accordion.min-1.11.4.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var mfn = {"mobileInit":"960","parallax":"translate3d","responsive":"1","sidebarSticky":"","lightbox":{"disable":false,"disableMobile":false,"title":false},"slider":{"blog":0,"clients":0,"offer":0,"portfolio":0,"shop":0,"slider":0,"testimonials":0}}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/plugins-21.6.0.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/menu-21.6.0.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/animations/animations.min-21.6.0.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/jplayer/jplayer.min-21.6.0.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/parallax/translate3d-21.6.0.1.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/scripts-21.6.0.1.js'></script> <script type='text/javascript'>.header-magazine #Top_bar .banner_wrapper { width: 720px !important; height: 90px !important; }
.header-magazine #Top_bar .banner_wrapper img { max-height: 90px !important; }</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js'></script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->