<!DOCTYPE html><html lang="en-US" class="no-js" itemscope itemtype="https://schema.org/Article"><head><meta charset="UTF-8" /> <script data-ad-client="ca-pub-5266060762538651" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><title>2020 NFL Draft Best Individual Skill Sets: Tight Ends | Waiting For Next Year</title><meta name="format-detection" content="telephone=no"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><link rel="shortcut icon" href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny2.png" type="image/x-icon" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//waitingfornext-a.akamaihd.net' /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Feed" href="https://waitingfornextyear.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; Comments Feed" href="https://waitingfornextyear.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Waiting For Next Year &raquo; 2020 NFL Draft Best Individual Skill Sets: Tight Ends Comments Feed" href="https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://waitingfornextyear.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wpt-twitter-feed-css' href='https://waitingfornextyear.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' /><link rel='stylesheet' id='style-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/style-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-base-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/base-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-layout-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/layout-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-shortcodes-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/shortcodes-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-animations-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/animations/animations.min-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-jquery-ui-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/ui/jquery.ui.all-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-jplayer-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/jplayer/css/jplayer.blue.monday-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-responsive-css' href='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/css/responsive-21.5.5.css' type='text/css' media='all' /><link rel='stylesheet' id='mfn-fonts-css' href='https://fonts.googleapis.com/css?family=Hind+Madurai%3A1%2C400%2C500%2C700%7CUbuntu%3A1%2C400%2C500%2C700%7CPatua+One%3A1%2C400%2C500%2C700&#038;ver=5.3.2' type='text/css' media='all' /><style id='mfn-dynamic-inline-css' type='text/css'>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</style><style id='mfn-custom-inline-css' type='text/css'>.footer-copy-center #Footer .footer_copy .copyright{font-size:12px;line-height:16px}.post-footer{display:none}</style><link rel='stylesheet' id='wdfb_style-css' href='https://waitingfornextyear.com/wp-content/plugins/wpmu-dev-facebook/css/wdfb.css' type='text/css' media='all' /> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js'></script> <link rel='https://api.w.org/' href='https://waitingfornextyear.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://waitingfornextyear.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://waitingfornextyear.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Waiting for next&#8230;month?: While We&#8217;re Waiting' href='https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/' /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://waitingfornextyear.com/?p=211024' /><meta property="fb:pages" content="20512657575" /><meta property="ia:markup_url" content="https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/?ia_markup=1" /><link type="text/css" rel="stylesheet" href="https://waitingfornextyear.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="@WFNYCLE" /><meta name="twitter:creator" content="@iggybrowns" /><meta name="twitter:url" content="https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/" /><meta name="twitter:title" content="2020 NFL Draft Best Individual Skill Sets: Tight Ends" /><meta name="twitter:description" content="WFNY&#039;s Joe Gilbert examines the top individual skill sets within the tight end class of the 2020 NFL Draft." /><meta name="twitter:image" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/1185546370.jpg.0.jpg" /> <style type="text/css">ol.footnotes li{list-style-type:decimal}</style><link rel="canonical" href="https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/" /><meta name="description" content="WFNY&#039;s Joe Gilbert examines the top individual skill sets within the tight end class of the 2020 NFL Draft." />  <script type="text/javascript">var _wdfb_ajaxurl="https://waitingfornextyear.com/wp-admin/admin-ajax.php";var _wdfb_root_url="https://waitingfornextyear.com/wp-content/plugins/wpmu-dev-facebook";</script><meta property='fb:app_id' content='106265117682' /><meta property='og:type' content='article' /><meta property='og:title' content='2020 NFL Draft Best Individual Skill Sets: Tight Ends' /><meta property='og:url' content='https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/' /><meta property='og:site_name' content='Waiting For Next Year' /><meta property='og:description' content='WFNY&#039;s Joe Gilbert examines the top individual skill sets within the tight end class of the 2020 NFL Draft.' /><meta property='og:image' content='https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/1185546370.jpg.0-1024x683.jpg' />  <script type="text/javascript">( function( i, s, o, g, r, a, m ) {
		i[ 'GoogleAnalyticsObject' ] = r;
		i[ r ] = i[ r ] || function() {
			( i[ r ].q = i[ r ].q || [] ).push( arguments )
		}, i[ r ].l = 1 * new Date();
		a = s.createElement( o ),
			m = s.getElementsByTagName( o )[ 0 ];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore( a, m )
	} )( window, document, 'script', 'https://waitingfornextyear.com/wp-content/cache/busting/google-tracking/ga-af5c617d36e28d19710b882a6824e213.js', 'beehive_ga' );

	function beehive_ga_track() {
		beehive_ga( 'create', 'UA-36605884-1', 'auto', { 'name': 'single' } ); // Create single site tracking.
		beehive_ga( 'single.send', 'pageview' ); // Send pageview.
	}

	beehive_ga_track(); // Load tracking.</script> <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-211024 single-format-standard with_aside aside_right color-custom style-default button-default layout-full-width if-disable if-border-hide hide-love no-shadows header-stack header-magazine minimalist-header sticky-header sticky-white ab-hide subheader-title-left menu-line-below-80-1 menuo-no-borders footer-copy-center boxed2fw mobile-tb-center mobile-mini-mr-ll mobile-header-mini be-reg-2155 wpb-js-composer js-comp-ver-6.1 vc_responsive"><div id="fb-root"></div> <script async defer src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=449813798444257&autoLogAppEvents=1"></script><div id="Wrapper"><div id="Header_wrapper" class="" ><header id="Header"><div class="header_placeholder"></div><div id="Top_bar" class="loading"><div class="container"><div class="column one"><div class="top_bar_left clearfix"><div class="logo"><a id="logo" href="https://waitingfornextyear.com" title="Waiting For Next Year" data-height="60" data-padding="10"><img class="logo-main scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /><img class="logo-sticky scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-dark.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-dark-2x.png" data-height="99" alt="wfny-logo-dark" data-no-retina /><img class="logo-mobile scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /><img class="logo-mobile-sticky scale-with-grid" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" data-retina="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-2x-.png" data-height="99" alt="wfny-logo-light-" data-no-retina /></a></div><div class="menu_wrapper"><nav id="menu"><ul id="menu-main-menu-2" class="menu menu-main"><li id="menu-item-204199" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-indians-archive/"><span>Indians</span></a></li><li id="menu-item-204205" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-browns-archive/"><span>Browns</span></a></li><li id="menu-item-204204" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/cleveland-cavs-archive/"><span>Cavs</span></a></li><li id="menu-item-204254" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/ohio-state-buckeyes-archive/"><span>Buckeyes</span></a></li><li id="menu-item-127673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#"><span>Other Sports</span></a><ul class="sub-menu"><li id="menu-item-204266" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/college-sports-archive/"><span>College Sports</span></a></li><li id="menu-item-204265" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/minor-league-baseball-archive/"><span>Minor League Baseball</span></a></li><li id="menu-item-204264" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/other-sports-archive/"><span>Other Sports</span></a></li></ul></li><li id="menu-item-204263" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://waitingfornextyear.com/podcast-archive/"><span>Podcast</span></a></li></ul></nav><a class="responsive-menu-toggle " href="#"><i class="icon-menu-fine"></i></a></div><div class="secondary_menu_wrapper"></div><div class="banner_wrapper"> <ins class="adsbygoogle" style="width:468px;height:60px" data-ad-client="ca-pub-5266060762538651" data-ad-slot="6641400053"></ins></div><div class="search_wrapper"><form method="get" id="searchform" action="https://waitingfornextyear.com/"> <i class="icon_search icon-search-fine"></i> <a href="#" class="icon_close"><i class="icon-cancel-fine"></i></a> <input type="text" class="field" name="s" placeholder="Enter your search" /> <input type="submit" class="display-none" value="" /></form></div></div></div></div></div></header><div id="Subheader"><div class="container"><div class="column one"><h1 class="title">2020 NFL Draft Best Individual Skill Sets: Tight Ends</h1></div></div></div></div><div id="Content"><div class="content_wrapper clearfix"><div class="sections_group"><div id="post-211024" class="no-title no-share share-simple post-211024 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft tag-2020-nfl-draft tag-browns tag-skill-sets tag-tight-ends"> <a class="fixed-nav fixed-nav-prev format- style-arrows" href="https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/"><span class="arrow"><i class="icon-left-open-big"></i></span><div class="photo"><img width="80" height="80" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/photo-1512736912-cd9db1d90b72-80x80.jpeg" class="attachment-blog-navi size-blog-navi wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/photo-1512736912-cd9db1d90b72-80x80.jpeg 80w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/photo-1512736912-cd9db1d90b72-150x150.jpeg 150w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/photo-1512736912-cd9db1d90b72-85x85.jpeg 85w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/photo-1512736912-cd9db1d90b72-45x45.jpeg 45w" sizes="(max-width: 80px) 100vw, 80px" /></div><div class="desc"><h6>Waiting for next&#8230;month?: While We&#8217;re Waiting</h6><span class="date"><i class="icon-clock"></i>March 13, 2020</span></div></a><div class="section section-post-header"><div class="section_wrapper clearfix"><div class="column one post-header"><div class="title_wrapper"><div class="post-meta clearfix"><div class="author-date"> <span class="vcard author post-author" itemprop="author" itemscope itemtype="https://schema.org/Person"> <span class="label">Published by</span> <i class="icon-user"></i> <span class="fn" itemprop="name"><a href="https://waitingfornextyear.com/author/joeyvgil/">Joe Gilbert</a></span> </span> <span class="date"> <span class="label">on</span> <i class="icon-clock"></i> <time class="entry-date updated" datetime="2020-03-13T09:55:08-04:00" itemprop="datePublished" >March 13, 2020</time><meta itemprop="dateModified" content="2020-03-13T09:55:08-04:00"/> </span><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization" style="display:none;"><meta itemprop="name" content="Waiting For Next Year"/><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png" itemprop="url" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/05/wfny-logo-light-.png"/></div></div></div></div></div></div><div class="column one single-photo-wrapper image"><div class="image_frame scale-with-grid "><div class="image_wrapper"> <a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/1185546370.jpg.0-1024x683.jpg" rel="prettyphoto"><div class="mask"></div><div itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><img width="1200" height="480" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/1185546370.jpg.0-1200x480.jpg" class="scale-with-grid wp-post-image" alt="" /><meta itemprop="url" content="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/1185546370.jpg.0.jpg"/><meta itemprop="width" content="1200"/><meta itemprop="height" content="800"/></div></a><div class="image_links"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/1185546370.jpg.0-1024x683.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a></div></div><p class="wp-caption-text hide">Abbie Parr/Getty Images</p></div></div></div></div><div class="post-wrapper-content"><div class="section the_content has_content"><div class="section_wrapper"><div class="the_content_wrapper"><div class="wdfb_like_button"><fb:like href="https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/" send="true" layout="button_count" width="450" colorscheme="light" show_faces="true" font=""></fb:like></div><p>Well, the sports scene is in uncharted territory because of the coronavirus. Most sports are on hold. But, the 2020 NFL Draft process is still in full swing, albeit in a less formal way as most teams are not taking visits from the prospects and not attending Pro Days. The draft season is also in full drive here at WFNY. We have been giving you our Mock Draft Wednesdays, my position rankings for the 2020 NFL Draft and following up each of those position rankings pieces by breaking down that position class’s top skill sets the next day. On Thursday, I examined the tight end position rankings. So, without further ado, here is how I see the tight end class and who possesses the top individual skill sets in this class.</p><p><strong>2020 NFL Draft Prospect Rankings:</strong> <a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-quarterbacks-20220/">Quarterbacks</a>, <a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-running-backs-2020/">Running Backs</a> and <a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/">Tight Ends</a></p><p><strong>2020 NFL Draft Best Individual Skill Sets:</strong> <a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-quarterbacks/">Quarterbacks</a> and <a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/">Running Backs</a></p><p><strong><u>Best Athlete</u></strong></p><div class="M2ZIjvX7" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-5266060762538651" data-ad-slot="2849801225"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>Hunter Bryant, Washington</strong></p><p>Bryant is a smooth athlete with almost receiver-like movement skills. He has the speed to run away from defenders, helping him gain separation in routes and after the catch. His agility allows him to get in and out routes well and after the catch, he can make defenders miss. Bryant is a great athlete.</p><p><strong><u>Best Ball Skills</u></strong></p><p><strong>Brycen Hopkins, Purdue</strong></p><p>Hopkins is a good athlete with a solid length. He uses both of these things in ball skills. He shows the ability to high point a catch over defenders. He is a hands catcher rather than a body catcher. He also shows the ability to catch passes in traffic and in the midst of being hit by a defender after the catch.</p><p><strong><u>Best Route Runner</u></strong></p><p><strong>Adam Trautman, Dayton</strong></p><p>Trautman has elite level agility. He moves like a receiver. This allows him to be a great route runner. He shows good wiggle to draw defenders in the wrong direction when he makes quick cuts. His route running is a tool for him to draw separation from his defender.</p><p><strong><u>Best Hands</u></strong></p><p><strong>Thaddeus Moss, LSU</strong></p><p>Moss had no drops last season according to Pro Football Focus. He shows soft and reliable hands to make contested catches. He plucks balls out of the air with his strong hands and is able to catch off-target passes.</p><p><strong><u>Best Player After the Catch</u></strong></p><p><strong>Hunter Bryant, Washington</strong></p><p>As I stated earlier, Bryant is a great athlete and that helps him in his ability after the catch. He is able to run away from defenders with his speed. He can elude defenders with his agility and has the balance to take on contact and stay upright. All this leads to big plays after the catch.</p><p><strong><u>Best Blocker</u></strong></p><p><strong>Thaddeus Moss, LSU</strong></p><p>Moss is a big man at 250 pounds and that shows in blocking ability. He is more than a willing blocker, showing toughness to get his hands dirty as a blocker. He shows solid technique and strength to help out as a pass and run blocker. From Day 1, Moss can be used as an extra blocker for NFL teams.</p><p><strong><u>Best Versatility</u></strong></p><p><strong>Adam Trautman, Dayton</strong></p><p>Trautman has the best versatility in the class. His athleticism, size and skill set allow him to fill many roles. He can be an in-line tight end because of his willingness and success as a blocker. He can line up on the outside and showcase his great route running to be a receiving threat. He can be a great mismatch in the passing game but also used as a blocker.</p><div class="wdfb_like_button"><fb:like href="https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/" send="true" layout="button_count" width="450" colorscheme="light" show_faces="true" font=""></fb:like></div></div></div></div><div class="section section-post-footer"><div class="section_wrapper clearfix"><div class="column one post-pager"></div></div></div><div class="section section-post-about"><div class="section_wrapper clearfix"></div></div></div><div class="section section-post-related"><div class="section_wrapper clearfix"><div class="section-related-adjustment "><h4>Related posts</h4><div class="section-related-ul col-3"><div class="column post-related post-211009 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft tag-2020-nfl-draft tag-browns tag-position-rankings tag-tight-ends"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/"><div class="mask"></div><img width="960" height="750" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Trautman_ADA-960x750.jpeg" class="scale-with-grid wp-post-image" alt="" srcset="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Trautman_ADA-960x750.jpeg 960w, https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Trautman_ADA-1280x1000.jpeg 1280w" sizes="(max-width: 960px) 100vw, 960px" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Trautman_ADA-1024x577.jpeg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/" class="link"><i class="icon-link"></i></a></div></div><p class="wp-caption-text hide">daytonflyers.com</p></div></div><div class="date_label">March 12, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/">2020 NFL Draft Prospect Rankings: Tight Ends</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div><div class="column post-related post-210982 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-www-2 tag-2020-nfl-draft tag-2020-nfl-mock-draft tag-andrew-thomas tag-browns tag-jedrick-wills tag-mekhi-becton tag-nfl-draft tag-nfl-mock-draft tag-tristan-wirfs"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/03/browns-nfl-mock-draft-roundup-5-0-pick-no-10/"><div class="mask"></div><img width="960" height="750" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Jedrick-Wills-960x750.jpg" class="scale-with-grid wp-post-image" alt="" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Jedrick-Wills-1024x576.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/03/browns-nfl-mock-draft-roundup-5-0-pick-no-10/" class="link"><i class="icon-link"></i></a></div></div><p class="wp-caption-text hide">Alabama Athletics</p></div></div><div class="date_label">March 11, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/03/browns-nfl-mock-draft-roundup-5-0-pick-no-10/">WFNY 2020 NFL Mock Draft Roundup 5.0: While We’re Waiting</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/03/browns-nfl-mock-draft-roundup-5-0-pick-no-10/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div><div class="column post-related post-210972 post type-post status-publish format-standard has-post-thumbnail hentry category-cleveland-browns category-nfl-draft tag-2020-nfl-draft tag-browns tag-running-backs tag-skill-sets"><div class="single-photo-wrapper image"><div class="image_frame scale-with-grid"><div class="image_wrapper"><a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/"><div class="mask"></div><img width="960" height="714" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/10/J.K.-Dobbins-960x714.jpg" class="scale-with-grid wp-post-image" alt="" /></a><div class="image_links double"><a href="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/10/J.K.-Dobbins-1024x714.jpg" class="zoom" rel="prettyphoto"><i class="icon-search"></i></a><a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/" class="link"><i class="icon-link"></i></a></div></div><p class="wp-caption-text hide">Kyle Robertson / The Columbus Dispatch</p></div></div><div class="date_label">March 10, 2020</div><div class="desc"><h4><a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/">2020 NFL Draft Best Individual Skill Sets: Running Backs</a></h4><hr class="hr_color" /><a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/" class="button button_left button_js"><span class="button_icon"><i class="icon-layout"></i></span><span class="button_label">Read more</span></a></div></div></div></div></div></div><div class="section section-post-comments"><div class="section_wrapper clearfix"><div class="column one comments"><div id="disqus_thread"></div></div></div></div></div></div><div class="sidebar sidebar-1 four columns"><div class="widget-area clearfix "><aside id="custom_html-2" class="widget_text widget widget_custom_html"><h3>WANT TO SUPPORT WFNY?</h3><div class="textwidget custom-html-widget"><a href="http://patreon.com/wfny" target="_blank" rel="nofollow noopener noreferrer"><img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2017/09/become_a_patron_button.png"></a></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><h3>BUY WFNY GEAR!</h3><div class="textwidget custom-html-widget"><a href="http://wfny.threadless.com/" target="_blank" rel="nofollow noopener noreferrer"><img src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2018/02/WFNYX-tshirt-sample.jpg"></a></div></aside><aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5266060762538651" data-ad-slot="7449450699" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><h3>WFNY PODCAST</h3><div class="textwidget custom-html-widget"><iframe style="border: none" src="//html5-player.libsyn.com/embed/destination/id/134539/height/500/theme/custom/thumbnail/yes/preload/no/direction/backward/no-cache/true/render-playlist/yes/custom-color/2e1094/" height="500" width="100%" scrolling="no" allowfullscreen webkitallowfullscreen mozallowfullscreen oallowfullscreen msallowfullscreen></iframe> <br><br> <a href="https://www.facebook.com/WFNYPod" target="_blank" rel="noopener noreferrer">The WFNY Podcast Facebook Page</a><br><br> <a href="https://itunes.apple.com/us/podcast/the-official-waiting-for-next-year-podcast/id569883258?mt=2" target="_blank" rel="noopener noreferrer">WFNY Podcast on iTunes</a></div></aside><aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="fb-page" data-href="https://www.facebook.com/waitingfornextyear/" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/waitingfornextyear/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/waitingfornextyear/">Waiting For Next Year - WFNY</a></blockquote></div></div></aside><style>.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type:none}.rpwe-block a{display:inline!important;text-decoration:none}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:14px!important;line-height:1.5em}.rpwe-thumb{border:1px solid #eee!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important}.rpwe-summary{font-size:12px}.rpwe-time{color:#bbb;font-size:11px}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px}.rpwe-alignleft{display:inline;float:left}.rpwe-alignright{display:inline;float:right}.rpwe-aligncenter{display:block;margin-left:auto;margin-right:auto}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table!important}.rpwe-clearfix:after{clear:both}.rpwe-clearfix{zoom:1}</style><aside id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h3>LOOK &#038; LISTEN</h3><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/photo-1512736912-cd9db1d90b72-scaled-45x45.jpeg" alt="Waiting for next&#8230;month?: While We&#8217;re Waiting"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/" title="Permalink to Waiting for next&#8230;month?: While We&#8217;re Waiting" rel="bookmark">Waiting for next&#8230;month?: While We&#8217;re Waiting</a></h3><time class="rpwe-time published" datetime="2020-03-13T08:55:59-04:00">March 13, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/announcing-the-viral-movie-podcast/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Ransom-Directive-45x45.jpg" alt="Announcing The Viral Movie Podcast"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/announcing-the-viral-movie-podcast/" title="Permalink to Announcing The Viral Movie Podcast" rel="bookmark">Announcing The Viral Movie Podcast</a></h3><time class="rpwe-time published" datetime="2020-03-12T15:42:41-04:00">March 12, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Trautman_ADA-45x45.jpeg" alt="2020 NFL Draft Prospect Rankings: Tight Ends"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-tight-ends-2020/" title="Permalink to 2020 NFL Draft Prospect Rankings: Tight Ends" rel="bookmark">2020 NFL Draft Prospect Rankings: Tight Ends</a></h3><time class="rpwe-time published" datetime="2020-03-12T08:55:50-04:00">March 12, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/mac-tournament-mid-american-conference-corona-virus-rocket-mortgage-fieldhouse-podcast/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/IMG_8601-scaled-45x45.jpg" alt="2020 MAC Tournament: Filled with suspense in an empty arena – The Nail in the Coffin, Episode 171"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/mac-tournament-mid-american-conference-corona-virus-rocket-mortgage-fieldhouse-podcast/" title="Permalink to 2020 MAC Tournament: Filled with suspense in an empty arena – The Nail in the Coffin, Episode 171" rel="bookmark">2020 MAC Tournament: Filled with suspense in an empty arena – The Nail in the Coffin, Episode 171</a></h3><time class="rpwe-time published" datetime="2020-03-11T09:55:12-04:00">March 11, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/browns-nfl-mock-draft-roundup-5-0-pick-no-10/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Jedrick-Wills-45x45.jpg" alt="WFNY 2020 NFL Mock Draft Roundup 5.0: While We’re Waiting"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/browns-nfl-mock-draft-roundup-5-0-pick-no-10/" title="Permalink to WFNY 2020 NFL Mock Draft Roundup 5.0: While We’re Waiting" rel="bookmark">WFNY 2020 NFL Mock Draft Roundup 5.0: While We’re Waiting</a></h3><time class="rpwe-time published" datetime="2020-03-11T08:55:02-04:00">March 11, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/ohio-state-buckeyes-ap-poll-top-25-no-19-big-ten-tournament/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Luther-Muhammad-45x45.png" alt="Ohio State remains at No. 19 in final AP Poll of regular season"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/ohio-state-buckeyes-ap-poll-top-25-no-19-big-ten-tournament/" title="Permalink to Ohio State remains at No. 19 in final AP Poll of regular season" rel="bookmark">Ohio State remains at No. 19 in final AP Poll of regular season</a></h3><time class="rpwe-time published" datetime="2020-03-10T10:55:09-04:00">March 10, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2019/10/J.K.-Dobbins-45x45.jpg" alt="2020 NFL Draft Best Individual Skill Sets: Running Backs"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/browns-2020-nfl-draft-skill-set-running-backs/" title="Permalink to 2020 NFL Draft Best Individual Skill Sets: Running Backs" rel="bookmark">2020 NFL Draft Best Individual Skill Sets: Running Backs</a></h3><time class="rpwe-time published" datetime="2020-03-10T09:55:03-04:00">March 10, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/ohio-state-buckeyes-assistants-four-million-dollar-men-ryan-day/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Ryan-Day-45x45.jpg" alt="Ohio State football assistants get big paydays ahead of 2020 season"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/ohio-state-buckeyes-assistants-four-million-dollar-men-ryan-day/" title="Permalink to Ohio State football assistants get big paydays ahead of 2020 season" rel="bookmark">Ohio State football assistants get big paydays ahead of 2020 season</a></h3><time class="rpwe-time published" datetime="2020-03-10T08:55:59-04:00">March 10, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/the-nail-tony-romo-youtube-tv-sinclair-podcast/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/IMG_8551-scaled-45x45.jpg" alt="Romo’s millions, YouTube TV vs. Sinclair, and more sports media headlines – The Nail in the Coffin, Episode 170"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/the-nail-tony-romo-youtube-tv-sinclair-podcast/" title="Permalink to Romo’s millions, YouTube TV vs. Sinclair, and more sports media headlines – The Nail in the Coffin, Episode 170" rel="bookmark">Romo’s millions, YouTube TV vs. Sinclair, and more sports media headlines – The Nail in the Coffin, Episode 170</a></h3><time class="rpwe-time published" datetime="2020-03-09T09:55:52-04:00">March 9, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-running-backs-2020/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://waitingfornext-a.akamaihd.net/wp-content/uploads/2020/03/Badgers1-45x45.jpeg" alt="2020 NFL Draft Prospect Rankings: Running Backs"></a><h3 class="rpwe-title"><a href="https://waitingfornextyear.com/2020/03/browns-nfl-draft-prospects-running-backs-2020/" title="Permalink to 2020 NFL Draft Prospect Rankings: Running Backs" rel="bookmark">2020 NFL Draft Prospect Rankings: Running Backs</a></h3><time class="rpwe-time published" datetime="2020-03-09T08:55:31-04:00">March 9, 2020</time></li></ul></div></aside></div></div></div></div> <script type="text/javascript" src="https://connect.facebook.net/en_US/all.js"></script><div id='fb-root'></div><script type='text/javascript'>FB.init({
	            appId: '106265117682',
	            status: true,
	            cookie: true,
	            xfbml: true,
	            oauth: true
	         });</script> <footer id="Footer" class="clearfix"><div class="widgets_wrapper"><div class="container"><div class="column one-third"><aside id="search-3" class="widget widget_search"><form method="get" id="searchform" action="https://waitingfornextyear.com/"> <i class="icon_search icon-search-fine"></i> <a href="#" class="icon_close"><i class="icon-cancel-fine"></i></a> <input type="text" class="field" name="s" placeholder="Enter your search" /> <input type="submit" class="display-none" value="" /></form></aside><aside id="text-280634579" class="widget widget_text"><div class="textwidget"><p><strong>Co-Founders/Editors:</strong><br /> <a href="https://waitingfornextyear.com/author/scottsargent/">Scott Sargent</a> (<a href="http://www.twitter.com/wfnyscott" target="_blank" rel="noopener noreferrer">@WFNYScott</a>)<br /> <a href="https://waitingfornextyear.com/author/admin/">Andrew Schnitkey</a> (<a href="http://www.twitter.com/rockwfny" target="_blank" rel="noopener noreferrer">@RockWFNY</a>)</p><p><strong>Associate Editors:</strong><br /> <a href="https://waitingfornextyear.com/author/mgbode/">Michael Bode</a> (<a href="http://www.twitter.com/mgbode_WFNY" target="_blank" rel="noopener noreferrer">@mgbode_WFNY</a>)<br /> <a href="https://waitingfornextyear.com/author/jgerberrry/">Joe Gerberry</a> (<a href="http://twitter.com/thegerbswfny" target=_blank">@TheGerbsWFNY</a>)</p><p><strong>Podcast Hosts:</strong><br /> <a href="https://waitingfornextyear.com/author/craig/">Craig Lyndall</a> <a href="http://www.twitter.com/wfnycraig" target="_blank" rel="noopener noreferrer">(@WFNYCraig</a>)<br /> <a href="https://waitingfornextyear.com/author/dimoko/">Dave Sterling</a> <a href="http://www.twitter.com/dimoko" target="_blank" rel="noopener noreferrer">(@dimoko</a>)<br /> <a href="https://waitingfornextyear.com/author/tvalentino">Tom Valentino</a> (<a href="twitter.com/1tomvalentino" target=_blank">@1TomValentino</a></p><p><strong>Contributors:</strong><br /> <a href="https://waitingfornextyear.com/author/coreybarnes/">Corey Barnes</a> (<a href="http://www.twitter.com/Corey_Barnes" target="_blank" rel="noopener noreferrer">@Corey_Barnes</a>)<br /> <a href="https://twitter.com/jake_burns18" target="_blank" rel="noopener noreferrer">Jake Burns</a> (<a href="https://twitter.com/jake_burns18" target="_blank" rel="noopener noreferrer">@jake_burns18</a>)<br /> <a href="https://twitter.com/JayTCannon" target="_blank" rel="noopener noreferrer">Jay Cannon</a> (<a href="https://twitter.com/JayTCannon" target="_blank" rel="noopener noreferrer">@JayTCannon</a>)<br /> <a href="https://twitter.com/thejaketakeblog" target="_blank" rel="noopener noreferrer">Chuck Chura</a> (<a href="https://twitter.com/thejaketakeblog" target="_blank" rel="noopener noreferrer">@thejaketakeblog</a>)<br /> <a href="https://twitter.com/JCozmo" target="_blank" rel="noopener noreferrer">John Colosimo</a> (<a href="https://twitter.com/JCozmo" target="_blank" rel="noopener noreferrer">@JCozmo</a>)<br /> <a href="https://waitingfornextyear.com/author/joeyvgil/">Joe Gilbert</a> (<a href="http://www.twitter.com/JoeGilbertWFNY" target="_blank" rel="noopener noreferrer">@JoeGilbertWFNY</a>)<br /> <a href="https://www.twitter.com/mlkrall" target="_blank" rel="noopener noreferrer">Mitchell Krall</a> (<a href="https://www.twitter.com/mlkrall" target="_blank" rel="noopener noreferrer">@mlkrall</a>)<br /> <a href="https://waitingfornextyear.com/author/jnomina/">Jeff Nomina</a> (<a href="http://www.twitter.com/SportsNom" target="_blank" rel="noopener noreferrer">@SportsNom</a>)<br /> <a href="https://twitter.com/TimROConnor">Tim O'Connor</a> (<a href="https://twitter.com/TimROConnor" target="_blank" rel="noopener noreferrer">@TimROConnor</a>)<br /> <a href="https://waitingfornextyear.com/author/jpete/">Jim Pete</a> (<a href="http://www.twitter.com/jimpeteehc" target="_blank" rel="noopener noreferrer">@JimPeteEHC</a>)<br /> <a href="https://waitingfornextyear.com/author/josh/">Josh Poloha</a> (<a href="https://twitter.com/jorshP" target="_blank" rel="noopener noreferrer">@JorshP</a>)<br /> <a href="https://www.twitter.com/sports7765" target="_blank" rel="noopener noreferrer">Frank Ryan</a> (<a href="https://www.twitter.com/sports7765" target="_blank" rel="noopener noreferrer">@sports7765</a>)</p><p><strong>Co-Founder Emeritus:</strong><br /> <a href="https://waitingfornextyear.com/author/rickg15/">Rick Grayshock</a> (<a href="http://www.twitter.com/rickgrayshock" target="_blank" rel="noopener noreferrer">@RickGrayshock</a>)</p><p><strong>Editors Emeritus:</strong><br /> <a href="https://waitingfornextyear.com/author/clayman">Andrew Clayman</a> (<a href="http://twitter.com/claymanwfny" target=_blank">@ClaymanWFNY</a>)<br /> <a href="https://waitingfornextyear.com/author/td/">TD Dery</a> (<a href="http://twitter.com/td1tribeku" target=_blank">@TD1TribeKU</a>)<br /> <a href="https://waitingfornextyear.com/author/willgibson/">Will Gibson</a> (<a href="http://twitter.com.com/wjcgibson" target=_blank">@wjcgibson</a>)<br /> <a href="https://waitingfornextyear.com/author/mhattery/">Mike Hattery</a> (<a href="http://www.twitter.com/snarkyhatman" target="_blank" rel="noopener noreferrer">@snarkyhatman</a>)<br /> <a href="https://waitingfornextyear.com/author/denny/">Denny Mayo</a> (<a href="http://www.twitter.com/dennymayo" target="_blank" rel="noopener noreferrer">@DennyMayo</a>)<br /> <a href="https://waitingfornextyear.com/author/dparker">Dan Parker</a> (<a href="http://www.twitter.com/dp_cannon" target="_blank" rel="noopener noreferrer">@DP_Cannon</a>)<br /> <a href="https://waitingfornextyear.com/author/brendan/">Brendan Porath</a> (<a href="http://twitter.com/brendanporath" target=_blank">@BrendanPorath</a>)<br /> <a href="https://waitingfornextyear.com/author/jacob/">Jacob Rosen</a> (<a href="http://www.twitter.com/wfnyjacob" target="_blank" rel="noopener noreferrer">@WFNYJacob</a>)<br /> <a href="https://waitingfornextyear.com/author/jsteiner/">Jon Steiner</a> (<a href="http://www.twitter.com/nowimjon" target="_blank" rel="noopener noreferrer">@NowImJon</a>)<br /> <a href="https://waitingfornextyear.com/author/kylewelch/">Kyle Welch</a> (<a href="http://www.twitter.com/kcwelch330" target="_blank" rel="noopener noreferrer">@kcwelch330</a>)<br /> <a href="https://waitingfornextyear.com/author/gwill">Gage Will</a> (<a href="http://twitter.com/gagewfny" target=_blank">@GageWFNY</a>)</p></div></aside></div><div class="column one-third"><aside id="rss-3" class="widget widget_rss"><h4><a class="rsswidget" href="http://wfnypod.libsyn.com/rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waitingfornext-a.akamaihd.net/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://wfnypod.libsyn.com/">WFNY Podcasts</a></h4><ul><li><a class='rsswidget' href='http://wfnypod.libsyn.com/covid-cancellations-lindor-talks-and-more'>COVID Cancellations, Lindor Talks, and More</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/frankie-cuts-off-talks-and-more-tribe-spring-training'>Frankie Cuts Off Talks and more Tribe Spring Training</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/dead-sports-scene-and-the-wait-and-see-browns'>Dead Sports Scene and the Wait and See Browns</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/spring-training-is-here'>Spring Training is Here!</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/john-beilein-is-out-and-it-doesnt-matter'>John Beilein is out and it doesn&#039;t matter</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/the-entitlement-of-nba-reporters'>The Entitlement of NBA Reporters</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/catching-up-with-okpants'>Catching up with okpants</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/the-dery-bros-on-what-dolan-said'>The Dery Bros on What Dolan Said</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/paul-dolan-does-it-again'>Paul Dolan Does it Again</a></li><li><a class='rsswidget' href='http://wfnypod.libsyn.com/kevin-stefanski-hired-by-the-browns'>Kevin Stefanski Hired by the Browns</a></li></ul></aside><aside id="nav_menu-3" class="widget widget_nav_menu"><h4>WFNY Links</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-127682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127682"><a href="https://waitingfornextyear.com/wfny-opportunities/">WFNY Opportunities</a></li><li id="menu-item-127683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-127683"><a href="https://waitingfornextyear.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-127684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127684"><a href="https://waitingfornextyear.com/before-you-comment/">Before You Comment</a></li><li id="menu-item-127685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127685"><a href="https://waitingfornextyear.com/about/">About</a></li><li id="menu-item-127686" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127686"><a href="https://www.facebook.com/waitingfornextyear">WFNY Facebook Page</a></li><li id="menu-item-127687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127687"><a href="http://www.tiqiq.com/wfny/cleveland-tickets">WFNY Tickets</a></li></ul></div></aside></div><div class="column one-third"><aside id="rss-5" class="widget widget_rss"><h4><a class="rsswidget" href="http://wfny.disqus.com/latest.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waitingfornext-a.akamaihd.net/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://wfny.disqus.com/">RECENT COMMENTS</a></h4><ul><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/#comment-4831838760'>Re: Waiting for next…month?: While We’re Waiting</a><div class="rssSummary">Appears most of those talking head shows have been suspended as well. No news on what ESPN will play in their place, yet.</div> <cite>mgbode</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/#comment-4831581568'>Re: Waiting for next…month?: While We’re Waiting</a><div class="rssSummary">I didn&#039;t know the Four Letter Classic still existed.</div> <cite>RGB</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/#comment-4831560579'>Re: Waiting for next…month?: While We’re Waiting</a><div class="rssSummary">Good article, Tom.This would be a good time to . . . oh, I don&#039;t know . . . maybe reveal new uniforms?I would love to see the TV networks replay some classic March Madness games of the past, such as Cleveland State&#039;s win over Indiana, mighty Georgetown&#039;s one-point win over Princeton, Butler&#039;s almost upset [&hellip;]</div> <cite>MartyDaVille</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/03/2020-nfl-draft-best-individual-skill-sets-tight-ends/#comment-4831498825'>Re: 2020 NFL Draft Best Individual Skill Sets: Tight Ends</a><div class="rssSummary">Sign me up for Son Of Randy.</div> <cite>RGB</cite></li><li><a class='rsswidget' href='https://waitingfornextyear.com/2020/03/coronavirus-sports-suspended-canceled/#comment-4831408156'>Re: Waiting for next…month?: While We’re Waiting</a><div class="rssSummary">Turn off the Four Letter for a month.Trey Wingo is absolutely reveling in spreading the panic. He reiterates every 5-minutes that he is not a medical expert, but he certainly does love to promote the most extreme positions. He is the worst.Fortunately not even he and his over the top virtue signalling can halt NFL [&hellip;]</div> <cite>RGB</cite></li></ul></aside></div></div></div><div class="footer_copy"><div class="container"><div class="column one"> <a id="back_to_top" class="button button_js" href=""><i class="icon-up-open-big"></i></a><div class="copyright"> © 2008-<script>document.write(new Date().getFullYear());</script> Waiting for Next Year, LLC<br/>Thanks to <a href="https://shoutitoutdesign.com" target="_blank" rel="nofollow">Shout It Out Design</a></div><ul class="social"></ul></div></div></div></footer></div>  <script type='text/javascript'>/* <![CDATA[ */ r3f5x9JS=escape(document['referrer']);
hf4N='e91f5e0703dd63d8c01214951562ea72';
hf4V='d94b334cfd63230bc33b0fcfe388e2a1';
cm4S="form[action='https://waitingfornextyear.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});}); /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var countVars = {"disqusShortname":"wfny"}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/plugins/disqus-comment-system/public/js/comment_count-3.0.17.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"211024 https:\/\/waitingfornextyear.com\/?p=211024","disqusShortname":"wfny","disqusTitle":"2020 NFL Draft Best Individual Skill Sets: Tight Ends","disqusUrl":"https:\/\/waitingfornextyear.com\/2020\/03\/2020-nfl-draft-best-individual-skill-sets-tight-ends\/","postId":"211024"}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/plugins/disqus-comment-system/public/js/comment_embed-3.0.17.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/core.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/widget.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/mouse.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/sortable.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/tabs.min-1.11.4.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-includes/js/jquery/ui/accordion.min-1.11.4.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var mfn = {"mobileInit":"960","parallax":"translate3d","responsive":"1","lightbox":{"disable":false,"disableMobile":false,"title":false},"slider":{"blog":0,"clients":0,"offer":0,"portfolio":0,"shop":0,"slider":0,"testimonials":0}}; /* ]]> */</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/plugins-21.5.5.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/menu-21.5.5.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/animations/animations.min-21.5.5.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/assets/jplayer/jplayer.min-21.5.5.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/parallax/translate3d-21.5.5.js'></script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/cache/busting/1/wp-content/themes/betheme/js/scripts-21.5.5.js'></script> <script type='text/javascript'>.header-magazine #Top_bar .banner_wrapper { width: 720px !important; height: 90px !important; }
.header-magazine #Top_bar .banner_wrapper img { max-height: 90px !important; }</script> <script type='text/javascript' src='https://waitingfornextyear.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js'></script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->